summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2011-06-11 02:11:30 +0300
committerAndrei Karas <akaras@inbox.ru>2011-06-11 02:11:30 +0300
commit2b9a98dc69ee75d410a277f9fb0da9767a8b837d (patch)
tree63b718d441c30f8f9b3a1219e5dcff505f5488ef /configure.ac
parentf7ad40eea337920240ba73a1a11feba6b4761ca3 (diff)
downloadplus-2b9a98dc69ee75d410a277f9fb0da9767a8b837d.tar.gz
plus-2b9a98dc69ee75d410a277f9fb0da9767a8b837d.tar.bz2
plus-2b9a98dc69ee75d410a277f9fb0da9767a8b837d.tar.xz
plus-2b9a98dc69ee75d410a277f9fb0da9767a8b837d.zip
Add configure keys for google perfomance tools.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index db6dae2e7..065f389c0 100755
--- a/configure.ac
+++ b/configure.ac
@@ -191,6 +191,30 @@ esac],[memdebug_enabled=false])
AM_CONDITIONAL(ENABLE_MEM_DEBUG, test x$memdebug_enabled = xtrue)
+# Enable tcmalloc
+AC_ARG_ENABLE(tcmalloc,
+[ --enable-tcmalloc Turn on tcmalloc],
+[case "${enableval}" in
+ yes) tcmalloc_enabled=true
+LIBS="$LIBS -ltcmalloc"
+ ;;
+ no) tcmalloc_enabled=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-tcmalloc) ;;
+esac],[tcmalloc_enabled=false])
+
+# Enable google profiler
+AC_ARG_ENABLE(googleprofiler,
+[ --enable-googleprofiler Turn on google profiler],
+[case "${enableval}" in
+ yes) googleprofiler_enabled=true
+LIBS="$LIBS -lprofiler"
+ ;;
+ no) googleprofiler_enabled=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-googleprofiler) ;;
+esac],[googleprofiler_enabled=false])
+
+AM_CONDITIONAL(ENABLE_GOOGLE_PROFILER, test x$googleprofiler_enabled = xtrue)
+
AC_CONFIG_FILES([
manaplus.spec
Makefile