summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2012-02-11 18:32:53 +0300
committerAndrei Karas <akaras@inbox.ru>2012-02-11 18:32:53 +0300
commit1e255ec19ececda196874f751a81682169cf64c3 (patch)
treea972041a56d46ec4beb04141946b73091fbbca95 /configure.ac
parentc14086d6a08fb2ea644eec9fafa0374604c98991 (diff)
downloadplus-1e255ec19ececda196874f751a81682169cf64c3.tar.gz
plus-1e255ec19ececda196874f751a81682169cf64c3.tar.bz2
plus-1e255ec19ececda196874f751a81682169cf64c3.tar.xz
plus-1e255ec19ececda196874f751a81682169cf64c3.zip
Add support for gtest framework.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ef92317d6..996ad3f3c 100755
--- a/configure.ac
+++ b/configure.ac
@@ -209,6 +209,19 @@ esac],[memdebug_enabled=false])
AM_CONDITIONAL(ENABLE_MEM_DEBUG, test x$memdebug_enabled = xtrue)
+# Enable unit tests
+AC_ARG_ENABLE(unittests,
+[ --enable-unittests Turn on unit tests],
+[case "${enableval}" in
+ yes) unittests_enabled=true
+LIBS="$LIBS -lgtest"
+ ;;
+ no) unittests_enabled=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-tests) ;;
+esac],[unittests_enabled=false])
+
+AM_CONDITIONAL(ENABLE_UNITTESTS, test x$unittests_enabled = xtrue)
+
# Enable tcmalloc
AC_ARG_ENABLE(tcmalloc,
[ --enable-tcmalloc Turn on tcmalloc],