summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2011-03-29 16:22:12 +0300
committerAndrei Karas <akaras@inbox.ru>2011-03-29 17:18:48 +0300
commit0cd441867adedc5add8b65a42d0f156e906ab25e (patch)
treedd133bd5396f74c5ece8b1b92b6c60747400379e /configure.ac
parentc36fbf56e9adc9de97e96acab753ddbb939c0b8b (diff)
downloadplus-0cd441867adedc5add8b65a42d0f156e906ab25e.tar.gz
plus-0cd441867adedc5add8b65a42d0f156e906ab25e.tar.bz2
plus-0cd441867adedc5add8b65a42d0f156e906ab25e.tar.xz
plus-0cd441867adedc5add8b65a42d0f156e906ab25e.zip
Add fixes for localisation dir in linux portable build and error detection.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b79d4261..74ed0d6b1 100755
--- a/configure.ac
+++ b/configure.ac
@@ -145,6 +145,17 @@ esac],[with_manaserv=false])
AM_CONDITIONAL(ENABLE_MANASERV, test x$with_manaserv = xtrue)
+# Enable portable
+AC_ARG_ENABLE(portable,
+[ --enable-portable Turn on portable mode for linux],
+[case "${enableval}" in
+ yes) portable_enabled=true ;;
+ no) portable_enabled=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-portable) ;;
+esac],[portable_enabled=false])
+
+AM_CONDITIONAL(ENABLE_PORTABLE, test x$portable_enabled = xtrue)
+
AC_CONFIG_FILES([
Makefile
src/Makefile