summaryrefslogtreecommitdiff
path: root/PKGBUILD.in
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2011-06-25 16:48:48 +0300
committerAndrei Karas <akaras@inbox.ru>2011-06-25 17:47:47 +0300
commitb5f2dcca2affb4d92663d870acba2b4ca1611d00 (patch)
tree5286465d42e6b7e60735751b1aea6443dc386fb0 /PKGBUILD.in
parent90982a892d9820663bde5f62ccc333841a547d69 (diff)
downloadplus-b5f2dcca2affb4d92663d870acba2b4ca1611d00.tar.gz
plus-b5f2dcca2affb4d92663d870acba2b4ca1611d00.tar.bz2
plus-b5f2dcca2affb4d92663d870acba2b4ca1611d00.tar.xz
plus-b5f2dcca2affb4d92663d870acba2b4ca1611d00.zip
add PKGBUILD to build system.
Diffstat (limited to 'PKGBUILD.in')
-rw-r--r--PKGBUILD.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD.in b/PKGBUILD.in
new file mode 100644
index 000000000..a4a08b913
--- /dev/null
+++ b/PKGBUILD.in
@@ -0,0 +1,19 @@
+# Maintainer: Aline Ferraz <freya.df@gmail.com>
+
+pkgname=manaplus-git
+pkgver=@PACKAGE_VERSION@
+pkgrel=1
+pkgdesc="ManaPlus is a 2D MMORPG game advanced client for games based on eAthena fork The Mana World (tAthena) also for other forks like Evol. More info here: http://manaplus.evolonline.org"
+arch=('i686' 'x86_64')
+url="http://manaplus.evolonline.org"
+depends=('libxml2' 'physfs' 'sdl_image' 'sdl_mixer' 'sdl_net' 'sdl_ttf' 'sdl_gfx')
+license=('GPL2')
+
+build() {
+cd ${startdir}/
+autoreconf -i
+./configure --prefix=/usr
+make clean
+make || return 1
+make DESTDIR=$startdir/pkg install
+}