summaryrefslogtreecommitdiff
path: root/src/tool/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tool/CMakeLists.txt')
-rw-r--r--src/tool/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/tool/CMakeLists.txt b/src/tool/CMakeLists.txt
index 26595b404..4dc500fc7 100644
--- a/src/tool/CMakeLists.txt
+++ b/src/tool/CMakeLists.txt
@@ -27,14 +27,12 @@ add_executable( mapcache ${SOURCE_FILES} )
include_directories( ${INCLUDE_DIRS} )
target_link_libraries( mapcache ${LIBRARIES} )
set_target_properties( mapcache PROPERTIES COMPILE_FLAGS "${DEFINITIONS}" )
-if( WITH_COMPONENT_RUNTIME )
+if( INSTALL_COMPONENT_RUNTIME )
cpack_add_component( Runtime_mapcache DESCRIPTION "mapcache generator" DISPLAY_NAME "mapcache" GROUP Runtime )
install( TARGETS mapcache
DESTINATION "."
COMPONENT Runtime_mapcache )
-endif()
-set( HAVE_mapcache ON CACHE BOOL "mapcache target is available" )
-mark_as_advanced( HAVE_mapcache )
+endif( INSTALL_COMPONENT_RUNTIME )
set( TARGET_LIST ${TARGET_LIST} mapcache CACHE INTERNAL "" )
message( STATUS "Creating target mapcache - done" )
else()