summaryrefslogtreecommitdiff
path: root/src/map/txt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/map/txt/CMakeLists.txt')
-rw-r--r--src/map/txt/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/map/txt/CMakeLists.txt b/src/map/txt/CMakeLists.txt
index 544e00c87..d58866f96 100644
--- a/src/map/txt/CMakeLists.txt
+++ b/src/map/txt/CMakeLists.txt
@@ -81,7 +81,7 @@ set( DEPENDENCIES common_base )
set( LIBRARIES ${GLOBAL_LIBRARIES} )
set( INCLUDE_DIRS ${GLOBAL_INCLUDE_DIRS} )
set( DEFINITIONS ${GLOBAL_DEFINITIONS} TXT_ONLY )
-if( USE_PCRE )
+if( WITH_PCRE )
message( STATUS "Using PCRE" )
list( APPEND LIBRARIES ${PCRE_LIBRARIES} )
list( APPEND INCLUDE_DIRS ${PCRE_INCLUDE_DIRS} )
@@ -95,10 +95,11 @@ add_executable( map-server ${SOURCE_FILES} )
add_dependencies( map-server ${DEPENDENCIES} )
target_link_libraries( map-server ${LIBRARIES} ${DEPENDENCIES} )
set_target_properties( map-server PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
-if( INSTALL_RUN_DATA )
+if( WITH_COMPONENT_RUNTIME )
+ cpack_add_component( Runtime_mapserver_txt DESCRIPTION "map-server (txt version)" DISPLAY_NAME "map-server" GROUP Runtime )
install( TARGETS map-server
- DESTINATION ${CMAKE_INSTALL_PREFIX}
- COMPONENT "map-server" )
+ DESTINATION "."
+ COMPONENT Runtime_mapserver_txt )
endif()
message( STATUS "Creating target map-server - done" )
set( HAVE_map-server ON CACHE BOOL "map-server target is available" )