summaryrefslogtreecommitdiff
path: root/src/map/sql/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/map/sql/CMakeLists.txt')
-rw-r--r--src/map/sql/CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/src/map/sql/CMakeLists.txt b/src/map/sql/CMakeLists.txt
index bf2d7cefa..47c8e495c 100644
--- a/src/map/sql/CMakeLists.txt
+++ b/src/map/sql/CMakeLists.txt
@@ -82,15 +82,14 @@ set( SQL_MAP_SOURCES
"${SQL_MAP_SOURCE_DIR}/vending.c"
)
set( DEPENDENCIES common_sql )
-set( LIBRARIES ${GLOBAL_LIBRARIES} common_sql )
+set( LIBRARIES ${GLOBAL_LIBRARIES} )
set( INCLUDE_DIRS ${GLOBAL_INCLUDE_DIRS} ${COMMON_BASE_INCLUDE_DIRS} )
set( DEFINITIONS "${GLOBAL_DEFINITIONS} ${COMMON_BASE_DEFINITIONS}" )
if( WITH_PCRE )
message( STATUS "Enabled PCRE code" )
- set( DEPENDENCIES ${DEPENDENCIES} ${PCRE_DEPENDENCIES} )
set( LIBRARIES ${LIBRARIES} ${PCRE_LIBRARIES} )
set( INCLUDE_DIRS ${INCLUDE_DIRS} ${PCRE_INCLUDE_DIRS} )
- set( DEFINITIONS "${DEFINITIONS} ${PCRE_DEFINITIONS} -DPCRE_SUPPORT" )
+ set( DEFINITIONS "${DEFINITIONS} -DPCRE_SUPPORT" )
else()
message( STATUS "Disabled PCRE code" )
endif()
@@ -99,10 +98,8 @@ source_group( common FILES ${COMMON_BASE_HEADERS} ${COMMON_SQL_HEADERS} )
source_group( map FILES ${SQL_MAP_HEADERS} ${SQL_MAP_SOURCES} )
include_directories( ${INCLUDE_DIRS} )
add_executable( map-server_sql ${SOURCE_FILES} )
-if( DEPENDENCIES )
- add_dependencies( map-server_sql ${DEPENDENCIES} )
-endif()
-target_link_libraries( map-server_sql ${LIBRARIES} )
+add_dependencies( map-server_sql ${DEPENDENCIES} )
+target_link_libraries( map-server_sql ${LIBRARIES} ${DEPENDENCIES} )
set_target_properties( map-server_sql PROPERTIES COMPILE_FLAGS "${DEFINITIONS}" )
if( INSTALL_COMPONENT_RUNTIME )
cpack_add_component( Runtime_mapserver_sql DESCRIPTION "map-server (sql version)" DISPLAY_NAME "map-server_sql" GROUP Runtime )