summaryrefslogtreecommitdiff
path: root/src/login/txt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/login/txt/CMakeLists.txt')
-rw-r--r--src/login/txt/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/login/txt/CMakeLists.txt b/src/login/txt/CMakeLists.txt
index a8d1246b7..75e055903 100644
--- a/src/login/txt/CMakeLists.txt
+++ b/src/login/txt/CMakeLists.txt
@@ -28,17 +28,14 @@ add_executable( login-server ${SOURCE_FILES} )
add_dependencies( login-server ${DEPENDENCIES} )
target_link_libraries( login-server ${LIBRARIES} ${DEPENDENCIES} )
set_target_properties( login-server PROPERTIES COMPILE_FLAGS "${DEFINITIONS}" )
-if( WITH_COMPONENT_RUNTIME )
+if( INSTALL_COMPONENT_RUNTIME )
cpack_add_component( Runtime_loginserver_txt DESCRIPTION "login-server (txt version)" DISPLAY_NAME "login-server" GROUP Runtime )
install( TARGETS login-server
DESTINATION "."
COMPONENT Runtime_loginserver_txt )
-endif()
-set( HAVE_login-server ON CACHE BOOL "login-server target is available" )
-mark_as_advanced( HAVE_login-server )
+endif( INSTALL_COMPONENT_RUNTIME )
set( TARGET_LIST ${TARGET_LIST} login-server CACHE INTERNAL "" )
message( STATUS "Creating target login-server - done" )
else()
message( STATUS "Skipping target login-server (requires common_base)" )
-unset( HAVE_login-server CACHE )
endif()