summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 25 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2751d945e..ac0e7b436 100644
--- a/configure.in
+++ b/configure.in
@@ -37,6 +37,20 @@ AC_ARG_ENABLE(
#
+# packetver
+#
+AC_ARG_ENABLE(
+ [packetver],
+ AC_HELP_STRING(
+ [--enable-packetver=ARG],
+ [Sets the PACKETVER define of the map-server. (see src/map/clif.h)]
+ ),
+ [enable_packetver="$enableval"],
+ [enable_packetver=""]
+)
+
+
+#
# mapregsql
#
AC_ARG_ENABLE(
@@ -139,7 +153,8 @@ AC_ARG_WITH(
[zlib],
AC_HELP_STRING(
[--with-zlib=DIR],
- [root directory path of zlib installation (defaults to /usr/local or /usr if not found in /usr/local)]
+ [root directory path of zlib installation (defaults to /usr/local or /usr if not found in /usr/local).
+ Assumes that the header files are in DIR/include and the library files are in DIR/lib]
),
[
test -n "$withval" && ZLIB_HOME="$withval"
@@ -273,6 +288,14 @@ esac
#
+# Packetver
+#
+if test -n "$enable_packetver" ; then
+ CFLAGS="$CFLAGS -DPACKETVER=$enable_packetver"
+fi
+
+
+#
# Mapregsql
#
if test "$enable_mapregsql" = "yes" ; then
@@ -284,7 +307,7 @@ fi
# Debug
#
if test "$enable_debug" = "yes" ; then
- CFLAGS="$CFLAGS -DDEBUG"
+ CFLAGS="$CFLAGS -g -DDEBUG"
fi