summaryrefslogtreecommitdiff
path: root/src/txt-converter/char/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-10 23:46:51 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-10 23:46:51 +0000
commit8729e952e08aa1af4e315060208a405b759f1027 (patch)
tree248f705cf3a7d8f1292558d58692e5a1edbdf34d /src/txt-converter/char/CMakeLists.txt
parente165e4a1f7fe8b25d92834461c3bc8bdf2530f85 (diff)
downloadhercules-8729e952e08aa1af4e315060208a405b759f1027.tar.gz
hercules-8729e952e08aa1af4e315060208a405b759f1027.tar.bz2
hercules-8729e952e08aa1af4e315060208a405b759f1027.tar.xz
hercules-8729e952e08aa1af4e315060208a405b759f1027.zip
* CMake: added txt-converter targets, added warning for 64bit, added list of available targets.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14900 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'src/txt-converter/char/CMakeLists.txt')
-rw-r--r--src/txt-converter/char/CMakeLists.txt81
1 files changed, 81 insertions, 0 deletions
diff --git a/src/txt-converter/char/CMakeLists.txt b/src/txt-converter/char/CMakeLists.txt
new file mode 100644
index 000000000..dab0df76a
--- /dev/null
+++ b/src/txt-converter/char/CMakeLists.txt
@@ -0,0 +1,81 @@
+
+#
+# char-converter
+#
+if( WITH_MYSQL )
+message( STATUS "Creating target char-converter" )
+set( COMMON_HEADERS
+ ${COMMON_MINI_HEADERS}
+ "${COMMON_SOURCE_DIR}/mapindex.h"
+ "${COMMON_SOURCE_DIR}/sql.h"
+ "${COMMON_SOURCE_DIR}/timer.h"
+ )
+set( COMMON_SOURCES
+ ${COMMON_MINI_SOURCES}
+ "${COMMON_SOURCE_DIR}/mapindex.c"
+ "${COMMON_SOURCE_DIR}/sql.c"
+ "${COMMON_SOURCE_DIR}/timer.c"
+ )
+set( TXT_HEADERS
+ "${TXT_CHAR_SOURCE_DIR}/char.h"
+ "${TXT_CHAR_SOURCE_DIR}/int_pet.h"
+ "${TXT_CHAR_SOURCE_DIR}/int_storage.h"
+ "${TXT_CHAR_SOURCE_DIR}/inter.h"
+ "${TXT_CHAR_SOURCE_DIR}/int_party.h"
+ "${TXT_CHAR_SOURCE_DIR}/int_guild.h"
+ )
+set( TXT_SOURCES
+ "${TXT_CHAR_SOURCE_DIR}/char.c"
+ "${TXT_CHAR_SOURCE_DIR}/int_pet.c"
+ "${TXT_CHAR_SOURCE_DIR}/int_storage.c"
+ "${TXT_CHAR_SOURCE_DIR}/inter.c"
+ "${TXT_CHAR_SOURCE_DIR}/int_party.c"
+ "${TXT_CHAR_SOURCE_DIR}/int_guild.c"
+ )
+set( SQL_HEADERS
+ "${SQL_CHAR_SOURCE_DIR}/char.h"
+ "${SQL_CHAR_SOURCE_DIR}/int_pet.h"
+ "${SQL_CHAR_SOURCE_DIR}/int_storage.h"
+ "${SQL_CHAR_SOURCE_DIR}/inter.h"
+ "${SQL_CHAR_SOURCE_DIR}/int_party.h"
+ "${SQL_CHAR_SOURCE_DIR}/int_guild.h"
+ "${SQL_CHAR_SOURCE_DIR}/int_mercenary.h"
+ )
+set( SQL_SOURCES
+ "${SQL_CHAR_SOURCE_DIR}/char.c"
+ "${SQL_CHAR_SOURCE_DIR}/int_pet.c"
+ "${SQL_CHAR_SOURCE_DIR}/int_storage.c"
+ "${SQL_CHAR_SOURCE_DIR}/inter.c"
+ "${SQL_CHAR_SOURCE_DIR}/int_party.c"
+ "${SQL_CHAR_SOURCE_DIR}/int_guild.c"
+ "${SQL_CHAR_SOURCE_DIR}/int_mercenary.c"
+ )
+set( CONVERTER_SOURCES
+ "${CONVERTER_SOURCE_DIR}/char-converter.c"
+ )
+set( LIBRARIES ${GLOBAL_LIBRARIES} ${MYSQL_LIBRARIES} )
+set( INCLUDE_DIRS ${GLOBAL_INCLUDE_DIRS} ${MYSQL_INCLUDE_DIRS} )
+set( DEFINITIONS ${GLOBAL_DEFINITIONS} ${COMMON_MINI_DEFINITIONS} TXT_SQL_CONVERT )
+set( SOURCE_FILES ${COMMON_HEADERS} ${COMMON_SOURCES} ${TXT_HEADERS} ${TXT_SOURCES} ${SQL_HEADERS} ${SQL_SOURCES} ${CONVERTER_SOURCES} )
+source_group( common FILES ${COMMON_HEADERS} ${COMMON_SOURCES} )
+source_group( txt FILES ${TXT_HEADERS} ${TXT_SOURCES} )
+source_group( sql FILES ${SQL_HEADERS} ${SQL_SOURCES} )
+source_group( converter FILES ${CONVERTER_SOURCES} )
+include_directories( ${INCLUDE_DIRS} )
+add_executable( char-converter ${SOURCE_FILES} )
+target_link_libraries( char-converter ${LIBRARIES} )
+set_target_properties( char-converter PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
+if( WITH_COMPONENT_RUNTIME )
+ cpack_add_component( Runtime_charconverter DESCRIPTION "char-converter" DISPLAY_NAME "char-converter" GROUP Runtime )
+ install( TARGETS char-converter
+ DESTINATION "tools"
+ COMPONENT Runtime_charconverter )
+endif()
+set( HAVE_char-converter ON CACHE BOOL "char-converter target is available" )
+mark_as_advanced( HAVE_char-converter )
+set( TARGET_LIST ${TARGET_LIST} char-converter CACHE INTERNAL "" )
+message( STATUS "Creating target char-converter - done" )
+else()
+message( STATUS "Skipping target char-converter (requires MYSQL)" )
+unset( HAVE_char-converter CACHE )
+endif()