summaryrefslogtreecommitdiff
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-03-20 16:59:07 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-03-20 16:59:07 +0000
commitee36fd725c890c5156f1d777368eeb84d5a3922e (patch)
treebdbec3c90830fa82e78774f62032896de7a2ba1a /src/plugins/CMakeLists.txt
parent78fe9886d39b11a38903ffc513a70fa2b00e43f3 (diff)
downloadhercules-ee36fd725c890c5156f1d777368eeb84d5a3922e.tar.gz
hercules-ee36fd725c890c5156f1d777368eeb84d5a3922e.tar.bz2
hercules-ee36fd725c890c5156f1d777368eeb84d5a3922e.tar.xz
hercules-ee36fd725c890c5156f1d777368eeb84d5a3922e.zip
- Fixed CMake compilation (libconfig integrated into common_base).
- Chanced libconfig.h include directives to double-quoted form (never use the system version of libconfig.h). - Removed ShowError/ShowNotice from sig plugin (showmsg.c depends on core.c). git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@15737 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index 903a1ec6e..21ffc3994 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -151,17 +151,11 @@ option( BUILD_PLUGIN_sig "build sig plugin" OFF )
if( BUILD_PLUGIN_sig )
message( STATUS "Creating target sig" )
set( SIG_SOURCES
- "${COMMON_SOURCE_DIR}/malloc.c"
- "${COMMON_SOURCE_DIR}/malloc.h"
- "${COMMON_SOURCE_DIR}/showmsg.c"
- "${COMMON_SOURCE_DIR}/showmsg.h"
- "${COMMON_SOURCE_DIR}/strlib.c"
- "${COMMON_SOURCE_DIR}/strlib.h"
"${CMAKE_CURRENT_SOURCE_DIR}/sig.c"
)
set( LIBRARIES ${GLOBAL_LIBRARIES} )
set( INCLUDE_DIRS ${GLOBAL_INCLUDE_DIRS} )
-set( DEFINITIONS "${GLOBAL_DEFINITIONS} ${COMMON_MINI_DEFINITIONS} -DNO_MEMMGR" )
+set( DEFINITIONS "${GLOBAL_DEFINITIONS} -DNO_MEMMGR" )
set( SOURCE_FILES ${SIG_SOURCES} )
source_group( sig FILES ${SIG_SOURCES} )
include_directories( ${INCLUDE_DIRS} )