summaryrefslogtreecommitdiff
path: root/src/map/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-21 06:47:12 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-21 06:47:12 +0000
commit46a89b00ad6b0e4e90d8b5a4571ac7fd32eb6845 (patch)
treedf32957a4b64ff947e0878a3cf42a41a564c5d5b /src/map/sql/CMakeLists.txt
parent427ebfd9e94a68ca15ca6b51378b80871dde95b9 (diff)
downloadhercules-46a89b00ad6b0e4e90d8b5a4571ac7fd32eb6845.tar.gz
hercules-46a89b00ad6b0e4e90d8b5a4571ac7fd32eb6845.tar.bz2
hercules-46a89b00ad6b0e4e90d8b5a4571ac7fd32eb6845.tar.xz
hercules-46a89b00ad6b0e4e90d8b5a4571ac7fd32eb6845.zip
* CMake: Only install template files if they don't already exist.
* CMake: Added plugin targets. * CMake: Added options BUILD_* to build the converters and individual plugins. (default=OFF) * CMake: Added option WITH_CPACK for package creation. (default=ON) git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14918 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'src/map/sql/CMakeLists.txt')
-rw-r--r--src/map/sql/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/map/sql/CMakeLists.txt b/src/map/sql/CMakeLists.txt
index 591e3e65b..68a8b750a 100644
--- a/src/map/sql/CMakeLists.txt
+++ b/src/map/sql/CMakeLists.txt
@@ -95,17 +95,14 @@ add_executable( map-server_sql ${SOURCE_FILES} )
add_dependencies( map-server_sql ${DEPENDENCIES} )
target_link_libraries( map-server_sql ${LIBRARIES} ${DEPENDENCIES} )
set_target_properties( map-server_sql PROPERTIES COMPILE_FLAGS "${DEFINITIONS}" )
-if( WITH_COMPONENT_RUNTIME )
+if( INSTALL_COMPONENT_RUNTIME )
cpack_add_component( Runtime_mapserver_sql DESCRIPTION "map-server (sql version)" DISPLAY_NAME "map-server_sql" GROUP Runtime )
install( TARGETS map-server_sql
DESTINATION "."
COMPONENT Runtime_mapserver_sql )
-endif()
-set( HAVE_map-server_sql ON CACHE BOOL "map-server_sql target is available" )
-mark_as_advanced( HAVE_map-server_sql )
+endif( INSTALL_COMPONENT_RUNTIME )
set( TARGET_LIST ${TARGET_LIST} map-server_sql CACHE INTERNAL "" )
message( STATUS "Creating target map-server_sql - done" )
else()
message( STATUS "Skipping target map-server_sql (requires common_sql; optional PCRE)" )
-unset( HAVE_map-server_sql CACHE )
endif()