summaryrefslogtreecommitdiff
path: root/src/map/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-05 20:51:08 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-05 20:51:08 +0000
commit926c49812706623bfa352a38b171b64c62c51932 (patch)
tree1d565f11761cacadb1e2d1c4335160c7e2794e97 /src/map/CMakeLists.txt
parentb813d39a6d8a0a73558ee1749d34f53681cd83f3 (diff)
downloadhercules-926c49812706623bfa352a38b171b64c62c51932.tar.gz
hercules-926c49812706623bfa352a38b171b64c62c51932.tar.bz2
hercules-926c49812706623bfa352a38b171b64c62c51932.tar.xz
hercules-926c49812706623bfa352a38b171b64c62c51932.zip
* CMake: split txt and sql variants of login-server and map-server.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14886 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'src/map/CMakeLists.txt')
-rw-r--r--src/map/CMakeLists.txt151
1 files changed, 39 insertions, 112 deletions
diff --git a/src/map/CMakeLists.txt b/src/map/CMakeLists.txt
index 7189bbdd7..4ff85fa19 100644
--- a/src/map/CMakeLists.txt
+++ b/src/map/CMakeLists.txt
@@ -27,124 +27,51 @@ set( COMMON_SQL_SOURCES
"${COMMON_SOURCE_DIR}/sql.c"
)
set( MAP_SOURCES
- "atcommand.c"
- "battle.c"
- "battleground.c"
- "buyingstore.c"
- "chat.c"
- "chrif.c"
- "clif.c"
- "date.c"
- "duel.c"
- "guild.c"
- "homunculus.c"
- "instance.c"
- "intif.c"
- "itemdb.c"
- "log.c"
- "mail.c"
- "map.c"
- "mercenary.c"
- "mob.c"
- "npc.c"
- "npc_chat.c"
- "party.c"
- "path.c"
- "pc.c"
- "pet.c"
- "quest.c"
- "script.c"
- "searchstore.c"
- "skill.c"
- "status.c"
- "storage.c"
- "trade.c"
- "unit.c"
- "vending.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/atcommand.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/battle.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/battleground.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/buyingstore.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/chat.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/chrif.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/clif.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/date.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/duel.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/guild.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/homunculus.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/instance.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/intif.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/itemdb.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/log.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/mail.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/map.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/mercenary.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/mob.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/npc.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/npc_chat.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/party.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/path.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/pc.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/pet.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/quest.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/script.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/searchstore.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/skill.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/status.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/storage.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/trade.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/unit.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/vending.c"
)
set( MAP_TXT_SOURCES
- "mapreg_txt.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/mapreg_txt.c"
)
set( MAP_SQL_SOURCES
- "mapreg_sql.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/mapreg_sql.c"
)
#
-# map txt
+# targets
#
-if( USE_ZLIB )
-message ( STATUS "Creating target map-server" )
-set( LIBRARIES ${GLOBAL_LIBRARIES} ${ZLIB_LIBRARIES} )
-set( INCLUDE_DIRS ${GLOBAL_INCLUDE_DIRS} ${MT19937AR_INCLUDE_DIRS} ${ZLIB_INCLUDE_DIRS} )
-set( DEFINITIONS ${GLOBAL_DEFINITIONS} TXT_ONLY )
-if( USE_PCRE )
- message( STATUS "Using PCRE" )
- list( APPEND LIBRARIES ${PCRE_LIBRARIES} )
- list( APPEND INCLUDE_DIRS ${PCRE_INCLUDE_DIRS} )
-endif()
-if( PACKETVER )
- message( STATUS "Using PACKETVER=${PACKETVER}" )
- list( APPEND DEFINITIONS PACKETVER=${PACKETVER} )
-endif()
-if( WIN32 )
- list( APPEND LIBRARIES "oldnames.lib" "ws2_32.lib" )
- list( APPEND INCLUDE_DIRS ${MSINTTYPES_INCLUDE_DIRS} )
-endif()
-set( SOURCE_FILES ${MT19937AR_SOURCES} ${COMMON_SOURCES} ${MAP_SOURCES} ${MAP_TXT_SOURCES} )
-source_group( 3rdparty FILES ${MT19937AR_SOURCES} )
-source_group( common FILES ${COMMON_SOURCES} )
-source_group( map FILES ${MAP_SOURCES} ${MAP_TXT_SOURCES} )
-include_directories( ${INCLUDE_DIRS} )
-add_executable( map-server ${SOURCE_FILES} )
-target_link_libraries( map-server ${LIBRARIES} )
-set_target_properties( map-server PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
-if( INSTALL_RUN_DATA )
- install( TARGETS map-server
- DESTINATION ${CMAKE_INSTALL_PREFIX}
- COMPONENT "map-server" )
-endif()
-message ( STATUS "Creating target map-server - done" )
-else()
-message ( STATUS "Skipping target map-server (requires ZLIB; optional PCRE)" )
-endif()
-
-
-#
-# map sql
-#
-if( USE_ZLIB AND USE_MYSQL )
-message ( STATUS "Creating target map-server_sql" )
-set( LIBRARIES ${GLOBAL_LIBRARIES} ${ZLIB_LIBRARIES} ${MYSQL_LIBRARIES} )
-set( INCLUDE_DIRS ${GLOBAL_INCLUDE_DIRS} ${MT19937AR_INCLUDE_DIRS} ${ZLIB_INCLUDE_DIRS} ${MYSQL_INCLUDE_DIRS} ${COMMON_INCLUDE_DIRS} )
-set( DEFINITIONS ${GLOBAL_DEFINITIONS} )
-if( USE_PCRE )
- message( STATUS "Using PCRE" )
- list( APPEND LIBRARIES ${PCRE_LIBRARIES} )
- list( APPEND INCLUDE_DIRS ${PCRE_INCLUDE_DIRS} )
-endif()
-if( PACKETVER )
- message( STATUS "Using PACKETVER=${PACKETVER}" )
- list( APPEND DEFINITIONS PACKETVER=${PACKETVER} )
-endif()
-if( WIN32 )
- list( APPEND LIBRARIES "oldnames.lib" "ws2_32.lib" )
- list( APPEND INCLUDE_DIRS ${MSINTTYPES_INCLUDE_DIRS} )
-endif()
-set( SOURCE_FILES ${MT19937AR_SOURCES} ${COMMON_SOURCES} ${COMMON_SQL_SOURCES} ${MAP_SOURCES} ${MAP_SQL_SOURCES} )
-source_group( 3rdparty FILES ${MT19937AR_SOURCES} )
-source_group( common FILES ${COMMON_SOURCES} ${COMMON_SQL_SOURCES} )
-source_group( map FILES ${MAP_SOURCES} ${MAP_SQL_SOURCES} )
-include_directories( ${INCLUDE_DIRS} )
-add_executable( map-server_sql ${SOURCE_FILES} )
-target_link_libraries( map-server_sql ${LIBRARIES} )
-set_target_properties( map-server_sql PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
-if( INSTALL_RUN_DATA )
- install( TARGETS map-server_sql
- DESTINATION ${CMAKE_INSTALL_PREFIX}
- COMPONENT "map-server_sql" )
-endif()
-message ( STATUS "Creating target map-server_sql - done" )
-else()
-message ( STATUS "Skipping target map-server_sql (requires ZLIB and MYSQL; optional PCRE)" )
-endif()
+add_subdirectory( txt )
+add_subdirectory( sql )