summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorai4rei <ai4rei@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-10-07 21:35:12 +0000
committerai4rei <ai4rei@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-10-07 21:35:12 +0000
commit033373a5a75599f8607107cb28b97cc6a653b0b5 (patch)
treec520e925018ac7de37d05f690d357fcf55b56ec4 /src/CMakeLists.txt
parent692dd1e5737b01ef26ba889f60d013cb992c3cec (diff)
downloadhercules-033373a5a75599f8607107cb28b97cc6a653b0b5.tar.gz
hercules-033373a5a75599f8607107cb28b97cc6a653b0b5.tar.bz2
hercules-033373a5a75599f8607107cb28b97cc6a653b0b5.tar.xz
hercules-033373a5a75599f8607107cb28b97cc6a653b0b5.zip
* Merged changes from trunk [14895:14966/trunk].
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/branches/renewal@14967 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt22
1 files changed, 20 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0bf5b0eb6..7ec05e405 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,9 +1,27 @@
+#
+# setup and static libraries
+#
add_subdirectory( common )
+if( HAVE_common_base )
+ option( BUILD_TXT_SERVERS "build txt server executables" ON )
+else()
+ message( STATUS "Disabled txt server targets (requires common_base)" )
+endif()
+if( HAVE_common_sql )
+ option( BUILD_SQL_SERVERS "build sql server executables" ON )
+else()
+ message( STATUS "Disabled sql server targets (requires common_sql)" )
+endif()
+
+
+#
+# targets
+#
add_subdirectory( login )
add_subdirectory( char )
add_subdirectory( char_sql )
add_subdirectory( map )
add_subdirectory( tool )
-#add_subdirectory( txt-converter )
-#add_subdirectory( plugins )
+add_subdirectory( txt-converter )
+add_subdirectory( plugins )