summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreathenabot <eathenabot@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-12-11 21:06:25 +0000
committereathenabot <eathenabot@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-12-11 21:06:25 +0000
commit415e738feb188909dea60831aef07c4fb0fe0f17 (patch)
tree655d59ab571962a2b3fa2fdc492bee3b83b024cc /configure.in
parentd187830a9f19239d7f43729a51198ed9dd8c176f (diff)
downloadhercules-415e738feb188909dea60831aef07c4fb0fe0f17.tar.gz
hercules-415e738feb188909dea60831aef07c4fb0fe0f17.tar.bz2
hercules-415e738feb188909dea60831aef07c4fb0fe0f17.tar.xz
hercules-415e738feb188909dea60831aef07c4fb0fe0f17.zip
* Merged changes up to eAthena 15032.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@15065 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 0 insertions, 36 deletions
diff --git a/configure.in b/configure.in
index a9e4c289a..3aff089db 100644
--- a/configure.in
+++ b/configure.in
@@ -440,42 +440,6 @@ AC_COMPILE_IFELSE(
)
-#
-# DB_MANUAL_CAST_TO_UNION
-#
-AC_MSG_CHECKING([whether $CC is able to typecast to union])
-AC_COMPILE_IFELSE(
- [
- typedef union Foonion
- {
- int i;
- unsigned int ui;
- const char* s;
- }
- Foonion;
-
- int bar(Foonion onion)
- {
- return onion.i;
- }
-
- int foo(void)
- {
- int i = 0;
-
- return bar(((Foonion)(int)i));
- }
- ],
- [
- AC_MSG_RESULT([yes])
- ],
- [
- AC_MSG_RESULT([no])
- CFLAGS="$CFLAGS -DDB_MANUAL_CAST_TO_UNION"
- ]
-)
-
-
###############################################################################
# Check for libraries and header files.
#