summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Wilkemeyer <fw@f-ws.de>2016-01-10 10:56:22 +0100
committerAndrei Karas <akaras@inbox.ru>2016-07-08 19:57:11 +0300
commitc6f05662899417ad22c4fa3217e6c2ba2d27b5a3 (patch)
tree112a35960141c206025e41abd672b284d4495afe /configure.ac
parentc7b95260fa3f4d77138fa34710f60365f4c86c87 (diff)
downloadhercules-c6f05662899417ad22c4fa3217e6c2ba2d27b5a3.tar.gz
hercules-c6f05662899417ad22c4fa3217e6c2ba2d27b5a3.tar.bz2
hercules-c6f05662899417ad22c4fa3217e6c2ba2d27b5a3.tar.xz
hercules-c6f05662899417ad22c4fa3217e6c2ba2d27b5a3.zip
Added epoll as event-dispatcher on linux (instead of select())
Note: It will be enabled by default if configure detects that the system has support for epoll To enforce usage of select run configure with --enable-epoll=no
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 39 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7b7590813..0e1c6b8bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,6 +143,33 @@ AC_ARG_ENABLE(
#
+# Epoll
+#
+AC_ARG_ENABLE([epoll],
+ [AS_HELP_STRING([--enable-epoll],[use epoll(4) on Linux])],
+ [enable_epoll=$enableval], [enable_epoll=auto])
+if test x$enable_epoll = xno; then
+ have_linux_epoll=no
+else
+ AC_MSG_CHECKING([for Linux epoll(4)])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM(
+ [
+ #ifndef __linux__
+ #error This is not Linux
+ #endif
+ #include <sys/epoll.h>
+ ],
+ [epoll_create1 (EPOLL_CLOEXEC);])],
+ [have_linux_epoll=yes],
+ [have_linux_epoll=no])
+ AC_MSG_RESULT([$have_linux_epoll])
+fi
+if test x$enable_epoll,$have_linux_epoll = xyes,no; then
+ AC_MSG_ERROR([epoll support explicitly enabled but not available])
+fi
+
+
+#
# Obfuscation keys
#
AC_ARG_WITH(
@@ -1139,6 +1166,18 @@ case $enable_packetver_re in
esac
#
+# Epoll
+#
+case $have_linux_epoll in
+ "yes")
+ CPPFLAGS="$CPPFLAGS -DSOCKET_EPOLL"
+ ;;
+ "no")
+ # default value
+ ;;
+esac
+
+#
# Obfuscation keys
#
if test -n "$obfuscationkey1" -a -n "$obfuscationkey2" -a -n "$obfuscationkey3"; then