summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-10 23:46:51 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-10 23:46:51 +0000
commit8729e952e08aa1af4e315060208a405b759f1027 (patch)
tree248f705cf3a7d8f1292558d58692e5a1edbdf34d /CMakeLists.txt
parente165e4a1f7fe8b25d92834461c3bc8bdf2530f85 (diff)
downloadhercules-8729e952e08aa1af4e315060208a405b759f1027.tar.gz
hercules-8729e952e08aa1af4e315060208a405b759f1027.tar.bz2
hercules-8729e952e08aa1af4e315060208a405b759f1027.tar.xz
hercules-8729e952e08aa1af4e315060208a405b759f1027.zip
* CMake: added txt-converter targets, added warning for 64bit, added list of available targets.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14900 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 27 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8187627a..fb94c7c72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,6 +125,13 @@ if( Subversion_FOUND AND SVNVERSION )
endif()
+#
+# 3rdparty
+#
+add_subdirectory( 3rdparty )
+
+
+
#####################################################################
# package stuff
#
@@ -283,7 +290,25 @@ endif()
#
-# subdirectories
+# sources
#
-add_subdirectory( 3rdparty )
+set( TARGET_LIST CACHE INTERNAL "" )
add_subdirectory( src )
+
+
+#####################################################################
+# final checks and warnings
+#
+if( CMAKE_SIZEOF_VOID_P EQUAL 8 )
+ message( WARNING "64bit should work, but is not recommended." )
+elseif( NOT CMAKE_SIZEOF_VOID_P EQUAL 4 )
+ message( FATAL_ERROR "unexpected architecture (CMAKE_SIZEOF_VOID_P=${CMAKE_SIZEOF_VOID_P})" )
+endif()
+list( LENGTH TARGET_LIST _LEN )
+if( _LEN EQUAL 0 )
+ message( FATAL_ERROR "no targets available" )
+endif()
+message( STATUS "Available targets:" )
+foreach( _TARGET IN ITEMS ${TARGET_LIST} )
+ message( STATUS "\t${_TARGET}" )
+endforeach()