summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoreathenabot <eathenabot@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-12-11 21:06:25 +0000
committereathenabot <eathenabot@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-12-11 21:06:25 +0000
commit415e738feb188909dea60831aef07c4fb0fe0f17 (patch)
tree655d59ab571962a2b3fa2fdc492bee3b83b024cc /CMakeLists.txt
parentd187830a9f19239d7f43729a51198ed9dd8c176f (diff)
downloadhercules-415e738feb188909dea60831aef07c4fb0fe0f17.tar.gz
hercules-415e738feb188909dea60831aef07c4fb0fe0f17.tar.bz2
hercules-415e738feb188909dea60831aef07c4fb0fe0f17.tar.xz
hercules-415e738feb188909dea60831aef07c4fb0fe0f17.zip
* Merged changes up to eAthena 15032.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@15065 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 0 insertions, 25 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0aee569a3..51fc2e39e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -196,31 +196,6 @@ endif()
#
-# Test typecast to union
-#
-message( STATUS "Check for typecast to union" )
-set( SOURCECODE
- "typedef union Foonion{\n"
- " int i;\n"
- " unsigned int ui;\n"
- " const char* s;\n"
- "} Foonion;\n"
- "int get_i(Foonion onion){ return onion.i; }\n"
- "int main(int argc, char** argv){\n"
- " int i = 0;\n"
- " return get_i(((Foonion)(int)i));\n"
- "}\n"
- )
-CHECK_C_SOURCE_COMPILES( "${SOURCECODE}" HAVE_TYPECAST_TO_UNION )
-if( HAVE_TYPECAST_TO_UNION )
- message( STATUS "Check for typecast to union - yes" )
-else()
- message( STATUS "Check for typecast to union - no" )
- set_property( CACHE GLOBAL_DEFINITIONS PROPERTY VALUE "${GLOBAL_DEFINITIONS} -DDB_MANUAL_CAST_TO_UNION" )
-endif()
-
-
-#
# Test monotonic clock
#
# CLOCK_MONOTONIC clock for clock_gettime