summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoreathenabot <eathenabot@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-05-12 20:14:01 +0000
committereathenabot <eathenabot@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-05-12 20:14:01 +0000
commit2a28e9c80e2386961db84f5ce932b1e33f43b7b3 (patch)
treef83f743fcc1296e8e52ae78adcd6b9899024e07b /CMakeLists.txt
parenta56813476c822a9cf7a543a9e419255b70680bf0 (diff)
downloadhercules-2a28e9c80e2386961db84f5ce932b1e33f43b7b3.tar.gz
hercules-2a28e9c80e2386961db84f5ce932b1e33f43b7b3.tar.bz2
hercules-2a28e9c80e2386961db84f5ce932b1e33f43b7b3.tar.xz
hercules-2a28e9c80e2386961db84f5ce932b1e33f43b7b3.zip
* Merged changes up to eAthena 15095.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@16105 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83e021fc3..4d0771254 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -572,9 +572,7 @@ add_subdirectory( src )
#####################################################################
# final checks and warnings
#
-if( CMAKE_SIZEOF_VOID_P EQUAL 8 )
- message( WARNING "64bit should work, but is not recommended." )
-elseif( NOT CMAKE_SIZEOF_VOID_P EQUAL 4 )
+if( NOT (CMAKE_SIZEOF_VOID_P EQUAL 4) AND NOT (CMAKE_SIZEOF_VOID_P EQUAL 8) )
message( FATAL_ERROR "unexpected architecture (CMAKE_SIZEOF_VOID_P is ${CMAKE_SIZEOF_VOID_P})" )
endif()
list( LENGTH TARGET_LIST _LEN )