summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoreathenabot <eathenabot@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-05-13 17:14:43 +0000
committereathenabot <eathenabot@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-05-13 17:14:43 +0000
commit93dd8ad5d0d9e1888ff4b32afa1fb09dbdd80be9 (patch)
tree9995391f4ac6aad31a4271c2440148b404d30667 /CMakeLists.txt
parent7e930917355db2790835bcda2f6ae37e3ae3c05c (diff)
downloadhercules-93dd8ad5d0d9e1888ff4b32afa1fb09dbdd80be9.tar.gz
hercules-93dd8ad5d0d9e1888ff4b32afa1fb09dbdd80be9.tar.bz2
hercules-93dd8ad5d0d9e1888ff4b32afa1fb09dbdd80be9.tar.xz
hercules-93dd8ad5d0d9e1888ff4b32afa1fb09dbdd80be9.zip
- Full revert of r16105 and r16106.
* Merged changes up to eAthena 15094. git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@16110 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c08297b7..83e021fc3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -465,6 +465,7 @@ set( RUNTIME_FILES
"${CMAKE_CURRENT_SOURCE_DIR}/char-server.sh"
"${CMAKE_CURRENT_SOURCE_DIR}/charserv-sql.bat"
"${CMAKE_CURRENT_SOURCE_DIR}/dbghelp.dll"
+ "${CMAKE_CURRENT_SOURCE_DIR}/libmysql.dll"
"${CMAKE_CURRENT_SOURCE_DIR}/LICENSE"
"${CMAKE_CURRENT_SOURCE_DIR}/login-server.sh"
"${CMAKE_CURRENT_SOURCE_DIR}/logserv-sql.bat"
@@ -571,7 +572,9 @@ add_subdirectory( src )
#####################################################################
# final checks and warnings
#
-if( NOT (CMAKE_SIZEOF_VOID_P EQUAL 4) AND NOT (CMAKE_SIZEOF_VOID_P EQUAL 8) )
+if( CMAKE_SIZEOF_VOID_P EQUAL 8 )
+ message( WARNING "64bit should work, but is not recommended." )
+elseif( NOT CMAKE_SIZEOF_VOID_P EQUAL 4 )
message( FATAL_ERROR "unexpected architecture (CMAKE_SIZEOF_VOID_P is ${CMAKE_SIZEOF_VOID_P})" )
endif()
list( LENGTH TARGET_LIST _LEN )