summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7114ab591..2d681a341 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,8 @@
AUTOMAKE_OPTIONS = subdir-objects
+.rc.o:
+ ${WINDRES} -o $@ $<
+
# this need for enable asan in tests
#AM_TESTS_ENVIRONMENT = \
# ASAN_OPTIONS=detect_leaks=1
@@ -98,6 +101,11 @@ manaplus_SOURCES =
dyecmd_SOURCES =
endif
+if MINGW
+manaplus_SOURCES += manaplus.rc
+dyecmd_SOURCES += manaplus.rc
+endif
+
if ENABLE_CILKPLUS
dyecmd_CXXFLAGS += -DENABLE_CILKPLUS -fcilkplus -lcilkrts
manaplus_CXXFLAGS += -DENABLE_CILKPLUS -fcilkplus -lcilkrts
@@ -1956,6 +1964,10 @@ manaplustests_SOURCES = ${SRC} \
utils/dumplibs_unittest.cc \
utils/checkutils_unittest.cc
+if MINGW
+manaplustests_SOURCES += manaplus.rc
+endif
+
if USE_PHYSFS
manaplustests_SOURCES += \
fs/physfs/virtfsphys_unittest.cc