summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 193d5b8ca..b3482391c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -20,6 +20,9 @@ else
bin_PROGRAMS =
endif
endif
+if ENABLE_UNITTESTSBIN
+bin_PROGRAMS += manaplustests
+endif
dyecmd_CXXFLAGS = -DPKG_DATADIR=\""$(pkgdatadir)/"\" \
-DLOCALEDIR=\""$(localedir)"\" \
@@ -1932,9 +1935,6 @@ if ENABLE_MANAPLUSGAME
manaplus_SOURCES += ${SRC}
endif
-if ENABLE_UNITTESTS
-TESTS = manaplustests
-check_PROGRAMS = manaplustests
manaplustests_CXXFLAGS = ${manaplus_CXXFLAGS} \
-DUNITTESTS
manaplustests_LDFLAGS =
@@ -2008,8 +2008,11 @@ manaplustests_SOURCES += \
resources/map/maplayer_unittest.cc \
resources/resourcemanager/resourcemanager_unittest.cc \
gui/windowmanager_unittest.cc
-endif
+if ENABLE_UNITTESTS
+TESTS = manaplustests
+check_PROGRAMS = manaplustests
+endif
EXTRA_DIST = CMakeLists.txt \
winver.h.in \