summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ef92317d6..996ad3f3c 100755
--- a/configure.ac
+++ b/configure.ac
@@ -209,6 +209,19 @@ esac],[memdebug_enabled=false])
AM_CONDITIONAL(ENABLE_MEM_DEBUG, test x$memdebug_enabled = xtrue)
+# Enable unit tests
+AC_ARG_ENABLE(unittests,
+[ --enable-unittests Turn on unit tests],
+[case "${enableval}" in
+ yes) unittests_enabled=true
+LIBS="$LIBS -lgtest"
+ ;;
+ no) unittests_enabled=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-tests) ;;
+esac],[unittests_enabled=false])
+
+AM_CONDITIONAL(ENABLE_UNITTESTS, test x$unittests_enabled = xtrue)
+
# Enable tcmalloc
AC_ARG_ENABLE(tcmalloc,
[ --enable-tcmalloc Turn on tcmalloc],