summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac27
1 files changed, 12 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 23febd1c8..25e57e123 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ(2.60)
-AC_INIT([ManaPlus], [1.0], [akaras@inbox.ru], [manaplus])
+AC_INIT([ManaVerse], [1.0], [jak1@themanaworld.org], [manaverse])
AM_INIT_AUTOMAKE([1.9])
AC_LANG_CPLUSPLUS
@@ -188,14 +188,14 @@ fi
AM_CONDITIONAL(ENABLE_DYECMD, test x$with_dyecmd = xyes)
-# Option to enable ManaPlus game
-AC_ARG_WITH(manaplusgame,[ --without-manaplusgame don't build ManaPlus game ] )
-if test "x$with_manaplusgame" == "xno"; then
- with_manaplusgame=no
+# Option to enable ManaVerse game
+AC_ARG_WITH(manaversegame,[ --without-manaversegame don't build ManaVerse game client ] )
+if test "x$with_manaversegame" == "xno"; then
+ with_manaversegame=no
else
- with_manaplusgame=yes
+ with_manaversegame=yes
fi
-AM_CONDITIONAL(ENABLE_MANAPLUSGAME, test x$with_manaplusgame = xyes)
+AM_CONDITIONAL(ENABLE_MANAVERSEGAME, test x$with_manaversegame = xyes)
# Enable nacl build
AC_ARG_ENABLE(naclbuild,
@@ -379,7 +379,7 @@ if test "x$with_internalsdlgfx" == "xno"; then
AC_CHECK_HEADERS(SDL2_rotozoom.h, ,)
else
with_internalsdlgfx=yes
- AC_DEFINE(USE_INTERNALSDLGFX, 1, [Defines if ManaPlus should use internal sdlgfx2])
+ AC_DEFINE(USE_INTERNALSDLGFX, 1, [Defines if ManaVerse should use internal sdlgfx2])
fi
AM_CONDITIONAL(USE_INTERNALSDLGFX, test x$with_internalsdlgfx = xyes)
@@ -888,13 +888,11 @@ AC_CHECK_HEADERS([execinfo.h],
AM_CONDITIONAL(HAVE_EXECINFO, test x$have_execinfo = xyes)
AC_CONFIG_FILES([
-manaplus.spec
+manaverse.spec
Makefile
PKGBUILD
src/Makefile
data/Makefile
-data/evol/evol.desktop
-data/evol/Makefile
data/fonts/Makefile
data/fonts/src/Makefile
data/graphics/Makefile
@@ -937,17 +935,16 @@ docs/Makefile
po/Makefile.in
])
-AC_CONFIG_FILES([data/evol/evol], [chmod +x data/evol/evol])
AC_CONFIG_FILES([data/tmw/tmw], [chmod +x data/tmw/tmw])
AC_OUTPUT
echo
-if test "$with_manaplusgame" == "yes"; then
- echo "Enabled building manaplus game."
+if test "$with_manaversegame" == "yes"; then
+ echo "Enabled building manaverse game client."
fi
if test "$with_dyecmd" == "yes"; then
- echo "Enabled building dyecmd."
+ echo "Enabled building dyecmd tool."
fi
if test "$unittests_enabled" == true; then
echo "Enabled building unit tests."