summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4cecd7663..2ba061c9c 100755
--- a/configure.ac
+++ b/configure.ac
@@ -157,9 +157,14 @@ else
AC_DEFINE(USE_INTERNALSDLGFX, 1, [Defines if ManaPlus should use internal sdlgfx2])
fi
AM_CONDITIONAL(USE_INTERNALSDLGFX, test x$with_internalsdlgfx = xyes)
+
+AC_CHECK_HEADERS([SDL.h], ,
+AC_MSG_ERROR([ *** SDL library found but cannot find headers (http://www.libsdl.org/)]))
])
-AC_CHECK_SDL()
+if test "x$naclbuild_enabled" == "xfalse"; then
+ AC_CHECK_SDL()
+fi
# Search for *-config
AC_PATH_PROG(PKG_CONFIG, pkg-config)
@@ -178,9 +183,6 @@ else
fi
-AC_CHECK_HEADERS([SDL.h], ,
-AC_MSG_ERROR([ *** SDL library found but cannot find headers (http://www.libsdl.org/)]))
-
AC_CHECK_LIB([z], [inflate], ,
AC_MSG_ERROR([ *** Unable to find zlib (http://www.gzip.org/zlib/)]))
@@ -405,6 +407,10 @@ esac],[checkplugin_enabled=false])
AM_CONDITIONAL(ENABLE_CHECKPLUGIN, test x$checkplugin_enabled = xtrue)
+if test "x$naclbuild_enabled" == "xtrue"; then
+ AC_CHECK_SDL()
+fi
+
AC_CONFIG_FILES([
manaplus.spec
Makefile