summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-02-20 15:51:27 +0300
committerAndrei Karas <akaras@inbox.ru>2017-02-20 15:51:27 +0300
commitcf772ab6f9fdfe1647b9b7b79aab685ebc831f31 (patch)
tree25cdb35a8733efe3a4cb90e36cbb89e8e0c24c10 /src/Makefile.am
parent80ba4766d8ce9861f6d026e791abc741e3fed0f4 (diff)
downloadplus-cf772ab6f9fdfe1647b9b7b79aab685ebc831f31.tar.gz
plus-cf772ab6f9fdfe1647b9b7b79aab685ebc831f31.tar.bz2
plus-cf772ab6f9fdfe1647b9b7b79aab685ebc831f31.tar.xz
plus-cf772ab6f9fdfe1647b9b7b79aab685ebc831f31.zip
Fix some leaks in unit tests.
Add support for suppression some leaks in asan.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 320809175..7ccb9fd09 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,8 @@
AUTOMAKE_OPTIONS = subdir-objects
+AM_TESTS_ENVIRONMENT = \
+ ASAN_OPTIONS=detect_leaks=1
+
if ENABLE_MANAPLUSGAME
if ENABLE_DYECMD
bin_PROGRAMS = manaplus dyecmd