summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-08-04 19:32:05 +0300
committerAndrei Karas <akaras@inbox.ru>2016-08-04 20:45:39 +0300
commit31fd786e7eb5097814eab4df03c32be354fb203d (patch)
treed6a88f7f619f2fe7d6a42d4c31955938a9435020 /src/Makefile.am
parent0cd72c26170c6c1f4b66583e45d4591a32f72f3c (diff)
downloadplus-31fd786e7eb5097814eab4df03c32be354fb203d.tar.gz
plus-31fd786e7eb5097814eab4df03c32be354fb203d.tar.bz2
plus-31fd786e7eb5097814eab4df03c32be354fb203d.tar.xz
plus-31fd786e7eb5097814eab4df03c32be354fb203d.zip
Add support for string enums. Add Attributes string enum.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f84508526..47f553f53 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -709,6 +709,8 @@ SRC += events/actionevent.h \
enums/simpletypes/showemptyrows.h \
enums/simpletypes/skiperror.h \
enums/simpletypes/speech.h \
+ enums/simpletypes/stringdefines.h \
+ enums/simpletypes/stringdefines2.h \
enums/simpletypes/trading.h \
enums/simpletypes/tryremovecolors.h \
enums/simpletypes/useargs.h \
@@ -903,6 +905,8 @@ manaplus_SOURCES += main.cpp \
enums/being/actortype.h \
enums/being/attacktype.h \
enums/being/attributes.h \
+ enums/being/attributesstrings.cpp \
+ enums/being/attributesstrings.h \
enums/being/badgeindex.h \
dragdrop.h \
gui/shortcut/dropshortcut.cpp \