summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-09-21 23:43:31 +0300
committerAndrei Karas <akaras@inbox.ru>2015-09-21 23:44:58 +0300
commit0533718792de26406c56257e4aea7f28d898a132 (patch)
tree653a1244848224708d1383fd3187e15bac55be0d /src/CMakeLists.txt
parente3b02f3d1977ef6eb18d91474e113cba1d3de710 (diff)
downloadplus-0533718792de26406c56257e4aea7f28d898a132.tar.gz
plus-0533718792de26406c56257e4aea7f28d898a132.tar.bz2
plus-0533718792de26406c56257e4aea7f28d898a132.tar.xz
plus-0533718792de26406c56257e4aea7f28d898a132.zip
Define out packet variables in one place and in all files use only externs.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 39a94d052..99a2bd0e5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -580,6 +580,7 @@ SET(SRCS
net/packetlimiter.cpp
net/packetlimiter.h
net/protocolindefine.h
+ net/protocoloutdefine.h
net/protocoloutinclude.h
net/recvpacketdefine.h
resources/action.cpp
@@ -1483,6 +1484,7 @@ SET(SRCS_TMWA
net/tmwa/playerrecv.cpp
net/tmwa/playerrecv.h
net/tmwa/protocolin.h
+ net/tmwa/protocolout.cpp
net/tmwa/protocolout.h
net/tmwa/questhandler.cpp
net/tmwa/questhandler.h
@@ -1707,6 +1709,7 @@ SET(SRCS_EATHENA
net/eathena/playerrecv.cpp
net/eathena/playerrecv.h
net/eathena/protocolin.h
+ net/eathena/protocolout.cpp
net/eathena/protocolout.h
net/eathena/questhandler.cpp
net/eathena/questhandler.h