summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2012-01-22 18:31:25 +0100
committerAndrei Karas <akaras@inbox.ru>2012-01-24 21:46:13 +0300
commitb4e47fb41a19ca09c02bcd009b28cb7c3caa2256 (patch)
treeeada17175623f6281a83aced143bb0940758a547 /src/CMakeLists.txt
parent80f61e80228aa0fa617961a4ec30d954fcb15eba (diff)
downloadplus-b4e47fb41a19ca09c02bcd009b28cb7c3caa2256.tar.gz
plus-b4e47fb41a19ca09c02bcd009b28cb7c3caa2256.tar.bz2
plus-b4e47fb41a19ca09c02bcd009b28cb7c3caa2256.tar.xz
plus-b4e47fb41a19ca09c02bcd009b28cb7c3caa2256.zip
Use SDL_RWops directly on top of PhysFS
This avoids the creation of a temporary buffer containing a complete file for the sole purpose of wrapping it up in an SDL_RWops. The necessary wrapper is by Ryan C. Gordon and is included in the PhysFS repository under 'extras'. Reviewed-by: Yohann Ferreira Conflicts: mana.files src/CMakeLists.txt src/resources/resourcemanager.cpp src/resources/soundeffect.cpp
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index fd56c9cba..d2c003559 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -452,6 +452,8 @@ SET(SRCS
utils/mathutils.h
utils/paths.cpp
utils/paths.h
+ utils/physfsrwops.cpp
+ utils/physfsrwops.h
utils/process.cpp
utils/process.h
utils/stringutils.cpp