summaryrefslogtreecommitdiff
path: root/packaging/nacl/ports/sdl-gfx
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-12-19 14:23:52 +0300
committerAndrei Karas <akaras@inbox.ru>2015-12-19 14:23:52 +0300
commitd3fe6cbd77ac51c6d62ac6fffaf72a7825e7f853 (patch)
tree2e3d31568a5cf4f56e9da81e7954b56d3eadbdda /packaging/nacl/ports/sdl-gfx
parentbc28a803b641cb7b33829a6bfd5f9a704cf21fbe (diff)
downloadplus-d3fe6cbd77ac51c6d62ac6fffaf72a7825e7f853.tar.gz
plus-d3fe6cbd77ac51c6d62ac6fffaf72a7825e7f853.tar.bz2
plus-d3fe6cbd77ac51c6d62ac6fffaf72a7825e7f853.tar.xz
plus-d3fe6cbd77ac51c6d62ac6fffaf72a7825e7f853.zip
Update nacl ports.
Diffstat (limited to 'packaging/nacl/ports/sdl-gfx')
-rwxr-xr-xpackaging/nacl/ports/sdl-gfx/build.sh39
-rw-r--r--packaging/nacl/ports/sdl-gfx/nacl.patch14
2 files changed, 7 insertions, 46 deletions
diff --git a/packaging/nacl/ports/sdl-gfx/build.sh b/packaging/nacl/ports/sdl-gfx/build.sh
index e1572c9a1..f7bfe8572 100755
--- a/packaging/nacl/ports/sdl-gfx/build.sh
+++ b/packaging/nacl/ports/sdl-gfx/build.sh
@@ -1,36 +1,11 @@
-#!/bin/bash
-# Copyright (c) 2011 The Native Client Authors. All rights reserved.
+# Copyright (c) 2014 The Native Client Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
-#source pkg_info
-#source ../../build_tools/common.sh
+# sdl2-config --libs includes -lppapi which cannot be linked
+# with shared libraries, so for now we disable the shared build.
+# In the future we could instead filter out this flag or remove
+# it and force SDL2 programs to add it themselves.
+EXTRA_CONFIGURE_ARGS="--enable-mmx=no --host=nacl --disable-shared"
+export RANLIB=${NACLRANLIB}
-ConfigureStep() {
- Banner "Configuring ${PACKAGE_NAME}"
-
- export SDL_CONFIG=${NACLPORTS_LIBDIR}/../bin/sdl-config
- SDL_CFLAGS=`$SDL_CONFIG --cflags`
- SDL_LIBS=`$SDL_CONFIG --libs`
-
- # export the nacl tools
- export CC=${NACLCC}
- export CXX=${NACLCXX}
- export AR=${NACLAR}
- export RANLIB=${NACLRANLIB}
- export PKG_CONFIG_PATH=${NACLPORTS_LIBDIR}/pkgconfig
- export PKG_CONFIG_LIBDIR=${NACLPORTS_LIBDIR}
- export CFLAGS="${NACLPORTS_CFLAGS} $SDL_CFLAGS"
- export CXXFLAGS="${NACLPORTS_CXXFLAGS} $SDL_CFLAGS"
- export LDFLAGS=${NACLPORTS_LDFLAGS}
- export PATH=${NACL_BIN_PATH}:${PATH};
- export LIBS="-L${NACLPORTS_LIBDIR} -lppapi -lppapi_gles2 -lppapi_cpp -lnacl_io -lpthread -lstdc++ -lm -lnosys $SDL_LIBS"
- ${SRC_DIR}/autogen.sh
- ${SRC_DIR}/configure \
- --enable-mmx=no \
- --host=nacl \
- --prefix=${PREFIX}
-}
-
-PackageInstall
-exit 0
diff --git a/packaging/nacl/ports/sdl-gfx/nacl.patch b/packaging/nacl/ports/sdl-gfx/nacl.patch
deleted file mode 100644
index e01d8e85c..000000000
--- a/packaging/nacl/ports/sdl-gfx/nacl.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- SDL_gfx-2.0.24/configure.in 2012-08-05 20:25:55.000000000 +0400
-+++ SDL_gfx-2.0.24-nacl/configure.in 2013-10-29 22:58:03.825301123 +0400
-@@ -117,10 +117,7 @@
- fi
-
- dnl Check for SDL
--AM_PATH_SDL($SDL_VERSION,
-- :,
-- AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
--)
-+
- CFLAGS="$CFLAGS $SDL_CFLAGS"
- # Remove dependencies from 'sdl-config' not meant for us libraries:
- SDL_LIBS=$(echo "$SDL_LIBS" | sed -e 's/-lmingw32//' -e 's/-lSDLmain//')