summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2011-02-01 20:58:10 +0200
committerAndrei Karas <akaras@inbox.ru>2011-02-01 21:42:50 +0200
commit954ceb91ddd94985594996d6d3c50be7b5652626 (patch)
tree95b9a13368a5c561b380f34df95850276ec205ac /configure.ac
parentba1c188f7a1850761eb7d63fbaaeece6dfb2a256 (diff)
downloadplus-954ceb91ddd94985594996d6d3c50be7b5652626.tar.gz
plus-954ceb91ddd94985594996d6d3c50be7b5652626.tar.bz2
plus-954ceb91ddd94985594996d6d3c50be7b5652626.tar.xz
plus-954ceb91ddd94985594996d6d3c50be7b5652626.zip
Add ability to enable/disable manaserv with embedded enet.
Set manaserv disabled in automake and cmake by default but enabled in build scripts.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bb1085f77..7315832c5 100755
--- a/configure.ac
+++ b/configure.ac
@@ -134,6 +134,17 @@ AC_MSG_ERROR([ *** Unable to find SDL_net library]))
AC_CHECK_LIB(rt, shm_open, ,
AC_MSG_ERROR([ *** Unable to find librt library]))
+# Enable manaserv
+AC_ARG_ENABLE(manaserv,
+[ --enable-manaserv Turn on manaserv],
+[case "${enableval}" in
+ yes) with_manaserv=true ;;
+ no) with_manaserv=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-manaserv) ;;
+esac],[with_manaserv=false])
+
+AM_CONDITIONAL(ENABLE_MANASERV, test x$with_manaserv = xtrue)
+
AC_CONFIG_FILES([
Makefile
src/Makefile