summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-02-05 20:03:13 +0300
committerAndrei Karas <akaras@inbox.ru>2017-02-05 20:28:38 +0300
commit5b4774d352787626061752e8dba6377b25b64f66 (patch)
tree0f82cfa69eda9424f75336e9b0bf7b837b14bb54 /configure.ac
parentcfc63060bb553e8be91949e16d04b5801a7527eb (diff)
downloadplus-5b4774d352787626061752e8dba6377b25b64f66.tar.gz
plus-5b4774d352787626061752e8dba6377b25b64f66.tar.bz2
plus-5b4774d352787626061752e8dba6377b25b64f66.tar.xz
plus-5b4774d352787626061752e8dba6377b25b64f66.zip
Add configure option --enable-glibcdebug for enable libcstdc++ debug mode.
By default this option disabled.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3c91519a3..a44573698 100755
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,19 @@ esac],[asserts_enabled=true])
AM_CONDITIONAL(ENABLE_ASSERTS, test x$asserts_enabled = xtrue)
+# Enable -D_GLIBCXX_DEBUG
+AC_ARG_ENABLE(glibcdebug,
+[ --enable-glibcdebug Enable glibc++ debug mode],
+[case "${enableval}" in
+ yes) glibcdebug_enabled=true
+ ;;
+ no) glibcdebug_enabled=false
+ ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-glibcdebug) ;;
+esac],[glibcdebug_enabled=false])
+
+AM_CONDITIONAL(ENABLE_GLIBCDEBUG, test x$glibcdebug_enabled = xtrue)
+
# Checks for android.
AC_ARG_ENABLE(androidbuild,
[ --enable-androidbuild Turn on android building],