summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-03-04 22:01:23 +0300
committerAndrei Karas <akaras@inbox.ru>2017-03-04 22:03:55 +0300
commit26a73f3de5c439cab8198291acee6a1fe5452426 (patch)
tree85dc94b4f87123d60a2e777f41b01b3f6da27fb0 /configure.ac
parent7bc16e64bf729263b7560fd7c3436b251fb87ff6 (diff)
downloadplus-26a73f3de5c439cab8198291acee6a1fe5452426.tar.gz
plus-26a73f3de5c439cab8198291acee6a1fe5452426.tar.bz2
plus-26a73f3de5c439cab8198291acee6a1fe5452426.tar.xz
plus-26a73f3de5c439cab8198291acee6a1fe5452426.zip
Disable using physfs in all builds except cmake.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 67fcdefe3..8e895487b 100755
--- a/configure.ac
+++ b/configure.ac
@@ -261,15 +261,15 @@ AC_CHECK_LIB([z], [inflate], ,
AC_MSG_ERROR([ *** Unable to find zlib (http://www.gzip.org/zlib/)]))
# Option to enable physfs.
-AC_ARG_WITH(physfs,[ --without-physfs don't use physfs (experimental) ] )
-if test "x$with_physfs" == "xno"; then
- with_physfs=no
-else
+AC_ARG_WITH(physfs,[ --with-physfs use physfs (experimental) ] )
+if test "x$with_physfs" == "xyes"; then
with_physfs=yes
AC_CHECK_LIB([physfs], [PHYSFS_init], ,
AC_MSG_ERROR([ *** Unable to find PhysFS library (http://icculus.org/physfs/)]))
AC_CHECK_HEADERS([physfs.h], ,
AC_MSG_ERROR([ *** PhysFS library found but cannot find headers (http://icculus.org/physfs/)]))
+else
+ with_physfs=no
fi
AM_CONDITIONAL(USE_PHYSFS, test x$with_physfs = xyes)