summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am323
1 files changed, 205 insertions, 118 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d3926a70..ce51b12d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,34 +1,32 @@
AUTOMAKE_OPTIONS = subdir-objects
bin_PROGRAMS = tmw
+
+tmw_CXXFLAGS = -DPKG_DATADIR=\""$(pkgdatadir)/"\" \
+ -DLOCALEDIR=\""$(localedir)"\"
+
tmw_SOURCES = gui/widgets/avatar.cpp \
- gui/widgets/avatar.h \
- gui/widgets/dropdown.cpp \
+ gui/widgets/avatar.h \
+ gui/widgets/dropdown.cpp \
gui/widgets/dropdown.h \
gui/widgets/layout.cpp \
gui/widgets/layout.h \
+ gui/widgets/layouthelper.cpp \
+ gui/widgets/layouthelper.h \
gui/widgets/resizegrip.cpp \
gui/widgets/resizegrip.h \
gui/widgets/tab.cpp \
gui/widgets/tab.h \
gui/widgets/tabbedarea.cpp \
gui/widgets/tabbedarea.h \
- gui/box.h \
- gui/box.cpp \
gui/browserbox.cpp \
gui/browserbox.h \
- gui/buddywindow.cpp \
- gui/buddywindow.h \
gui/button.cpp \
gui/button.h \
gui/buy.cpp \
gui/buy.h \
gui/buysell.cpp \
gui/buysell.h \
- gui/changeemaildialog.cpp \
- gui/changeemaildialog.h \
- gui/changepassworddialog.cpp \
- gui/changepassworddialog.h \
gui/char_select.cpp \
gui/char_select.h \
gui/chat.cpp \
@@ -37,12 +35,18 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
gui/chatinput.h \
gui/checkbox.cpp \
gui/checkbox.h \
+ gui/color.cpp \
+ gui/color.h \
gui/confirm_dialog.cpp \
gui/confirm_dialog.h \
- gui/connection.cpp \
- gui/connection.h \
gui/debugwindow.cpp \
gui/debugwindow.h \
+ gui/emotecontainer.cpp \
+ gui/emotecontainer.h \
+ gui/emoteshortcutcontainer.cpp \
+ gui/emoteshortcutcontainer.h \
+ gui/emotewindow.cpp \
+ gui/emotewindow.h \
gui/equipmentwindow.cpp \
gui/equipmentwindow.h \
gui/focushandler.cpp \
@@ -51,30 +55,22 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
gui/gccontainer.h \
gui/gui.cpp \
gui/gui.h \
- gui/guildwindow.cpp \
- gui/guildwindow.h \
- gui/guildlistbox.cpp \
- gui/guildlistbox.h \
- gui/hbox.h \
- gui/hbox.cpp \
gui/help.cpp \
gui/help.h \
- gui/icon.h \
gui/icon.cpp \
- gui/inttextbox.h \
- gui/inttextbox.cpp \
+ gui/icon.h \
+ gui/inttextfield.cpp \
+ gui/inttextfield.h \
gui/inventorywindow.cpp \
gui/inventorywindow.h \
gui/itemcontainer.cpp \
gui/itemcontainer.h \
- gui/itemlinkhandler.cpp \
- gui/itemlinkhandler.h \
+ gui/itemlinkhandler.cpp \
+ gui/itemlinkhandler.h \
gui/itempopup.cpp \
gui/itempopup.h \
gui/itemshortcutcontainer.cpp \
gui/itemshortcutcontainer.h \
- gui/itemshortcutwindow.cpp \
- gui/itemshortcutwindow.h \
gui/item_amount.cpp \
gui/item_amount.h \
gui/linkhandler.h \
@@ -82,26 +78,22 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
gui/listbox.h \
gui/login.cpp \
gui/login.h \
- gui/magic.cpp \
- gui/magic.h \
gui/menuwindow.cpp \
gui/menuwindow.h \
gui/minimap.cpp \
gui/minimap.h \
gui/ministatus.cpp \
gui/ministatus.h \
+ gui/npcintegerdialog.cpp \
+ gui/npcintegerdialog.h \
gui/npclistdialog.cpp \
gui/npclistdialog.h \
- gui/npcpostdialog.cpp \
- gui/npcpostdialog.h \
+ gui/npcstringdialog.cpp \
+ gui/npcstringdialog.h \
gui/npc_text.cpp \
gui/npc_text.h \
gui/ok_dialog.cpp \
gui/ok_dialog.h \
- gui/truetypefont.cpp \
- gui/truetypefont.h \
- gui/partywindow.h \
- gui/partywindow.cpp \
gui/passwordfield.cpp \
gui/passwordfield.h \
gui/playerbox.cpp \
@@ -110,10 +102,10 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
gui/popupmenu.h \
gui/progressbar.cpp \
gui/progressbar.h \
- gui/quitdialog.cpp \
- gui/quitdialog.h \
gui/radiobutton.cpp \
gui/radiobutton.h \
+ gui/recorder.cpp \
+ gui/recorder.h \
gui/register.cpp \
gui/register.h \
gui/scrollarea.cpp \
@@ -122,16 +114,18 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
gui/sdlinput.h \
gui/sell.cpp \
gui/sell.h \
- gui/serverdialog.cpp \
- gui/serverdialog.h \
- gui/setup_audio.cpp \
- gui/setup_audio.h \
gui/setup.cpp \
gui/setup.h \
+ gui/setup_audio.cpp \
+ gui/setup_audio.h \
+ gui/setup_colors.cpp \
+ gui/setup_colors.h \
gui/setup_joystick.cpp \
gui/setup_joystick.h \
gui/setup_keyboard.cpp \
gui/setup_keyboard.h \
+ gui/setup_players.cpp \
+ gui/setup_players.h \
gui/setuptab.h \
gui/setup_video.cpp \
gui/setup_video.h \
@@ -139,14 +133,18 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
gui/shop.h \
gui/shoplistbox.cpp \
gui/shoplistbox.h \
- gui/skill.cpp \
- gui/skill.h \
+ gui/shortcutwindow.cpp \
+ gui/shortcutwindow.h \
+ gui/shortcutcontainer.cpp \
+ gui/shortcutcontainer.h \
gui/slider.cpp \
gui/slider.h \
gui/speechbubble.cpp \
gui/speechbubble.h \
- gui/status.cpp \
- gui/status.h \
+ gui/table.cpp \
+ gui/table.h \
+ gui/table_model.cpp \
+ gui/table_model.h \
gui/textbox.cpp \
gui/textbox.h \
gui/textdialog.cpp \
@@ -155,87 +153,36 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
gui/textfield.h \
gui/trade.cpp \
gui/trade.h \
- gui/unregisterdialog.cpp \
- gui/unregisterdialog.h \
- gui/updatewindow.h \
+ gui/truetypefont.cpp \
+ gui/truetypefont.h \
gui/updatewindow.cpp \
- gui/vbox.h \
- gui/vbox.cpp \
+ gui/updatewindow.h \
gui/viewport.cpp \
gui/viewport.h \
gui/window.cpp \
gui/window.h \
gui/windowcontainer.cpp \
gui/windowcontainer.h \
- net/beinghandler.h \
- net/beinghandler.cpp \
- net/buysellhandler.h \
- net/buysellhandler.cpp \
- net/charserverhandler.h \
- net/charserverhandler.cpp \
- net/chathandler.h \
- net/chathandler.cpp \
- net/connection.h \
- net/connection.cpp \
- net/guildhandler.cpp \
- net/guildhandler.h \
- net/internal.h \
- net/internal.cpp \
- net/inventoryhandler.h \
- net/inventoryhandler.cpp \
net/itemhandler.h \
net/itemhandler.cpp \
- net/loginhandler.h \
- net/loginhandler.cpp \
- net/logouthandler.cpp \
- net/logouthandler.h \
net/messagehandler.cpp \
net/messagehandler.h \
net/messagein.cpp \
net/messagein.h \
net/messageout.cpp \
net/messageout.h \
- net/network.cpp \
- net/network.h \
- net/npchandler.cpp \
- net/npchandler.h \
- net/partyhandler.cpp \
- net/partyhandler.h \
- net/playerhandler.cpp \
- net/playerhandler.h \
- net/protocol.h \
- net/tradehandler.cpp \
- net/tradehandler.h \
- net/effecthandler.h \
- net/effecthandler.cpp \
- net/accountserver/account.cpp \
- net/accountserver/account.h \
- net/accountserver/accountserver.cpp \
- net/accountserver/accountserver.h \
- net/accountserver/internal.cpp \
- net/accountserver/internal.h \
- net/chatserver/chatserver.cpp \
- net/chatserver/chatserver.h \
- net/chatserver/internal.cpp \
- net/chatserver/internal.h \
- net/chatserver/guild.cpp \
- net/chatserver/guild.h \
- net/chatserver/party.cpp \
- net/chatserver/party.h \
- net/gameserver/gameserver.cpp \
- net/gameserver/gameserver.h \
- net/gameserver/internal.cpp \
- net/gameserver/internal.h \
- net/gameserver/player.cpp \
- net/gameserver/player.h \
resources/action.cpp \
resources/action.h \
resources/ambientoverlay.cpp \
resources/ambientoverlay.h \
resources/animation.cpp \
resources/animation.h \
+ resources/colordb.cpp \
+ resources/colordb.h \
resources/dye.cpp \
resources/dye.h \
+ resources/emotedb.cpp \
+ resources/emotedb.h \
resources/image.cpp \
resources/image.h \
resources/imageloader.cpp \
@@ -266,20 +213,17 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
resources/soundeffect.cpp \
resources/spritedef.h \
resources/spritedef.cpp \
- resources/buddylist.h \
- resources/buddylist.cpp \
utils/base64.cpp \
utils/base64.h \
utils/dtor.h \
utils/fastsqrt.h \
utils/gettext.h \
- utils/minmax.h \
- utils/sha256.h \
utils/sha256.cpp \
+ utils/sha256.h \
+ utils/stringutils.cpp \
+ utils/stringutils.h \
utils/strprintf.cpp \
utils/strprintf.h \
- utils/tostring.h \
- utils/trim.h \
utils/mutex.h \
utils/xml.cpp \
utils/xml.h \
@@ -295,11 +239,13 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
channel.h \
channelmanager.cpp \
channelmanager.h \
- commandhandler.cpp \
- commandhandler.h \
configlistener.h \
configuration.cpp \
configuration.h \
+ effectmanager.cpp \
+ effectmanager.h \
+ emoteshortcut.cpp \
+ emoteshortcut.h \
engine.cpp \
engine.h \
equipment.cpp \
@@ -312,8 +258,6 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
game.h \
graphics.cpp \
graphics.h \
- guild.cpp \
- guild.h \
guichanfwd.h \
imageparticle.cpp \
imageparticle.h \
@@ -345,10 +289,15 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
openglgraphics.h \
particle.cpp \
particle.h \
+ particlecontainer.cpp \
+ particlecontainer.h \
particleemitter.cpp \
particleemitter.h \
+ particleemitterprop.h \
player.cpp \
player.h \
+ player_relations.cpp \
+ player_relations.h \
position.cpp \
position.h \
properties.h \
@@ -360,16 +309,154 @@ tmw_SOURCES = gui/widgets/avatar.cpp \
sound.cpp \
sound.h \
sprite.h \
+ statuseffect.cpp \
+ statuseffect.h \
+ text.cpp \
+ text.h \
+ textmanager.cpp \
+ textmanager.h \
textparticle.cpp \
textparticle.h \
tileset.h \
+ units.cpp \
+ units.h \
vector.cpp \
- vector.h \
- effectmanager.cpp \
- effectmanager.h
+ vector.h
+
+if SERVER_TMWSERV
+tmw_CXXFLAGS += -DTMWSERV_SUPPORT
+tmw_SOURCES += \
+ gui/buddywindow.cpp \
+ gui/buddywindow.h \
+ gui/changeemaildialog.cpp \
+ gui/changeemaildialog.h \
+ gui/changepassworddialog.cpp \
+ gui/changepassworddialog.h \
+ gui/connection.cpp \
+ gui/connection.h \
+ gui/guildlistbox.cpp \
+ gui/guildlistbox.h \
+ gui/guildwindow.cpp \
+ gui/guildwindow.h \
+ gui/magic.cpp \
+ gui/magic.h \
+ gui/npcpostdialog.cpp \
+ gui/npcpostdialog.h \
+ gui/partywindow.cpp \
+ gui/partywindow.h \
+ gui/quitdialog.cpp \
+ gui/quitdialog.h \
+ gui/serverdialog.cpp \
+ gui/serverdialog.h \
+ gui/skilldialog.cpp \
+ gui/skilldialog.h \
+ gui/statuswindow.cpp \
+ gui/statuswindow.h \
+ gui/unregisterdialog.cpp \
+ gui/unregisterdialog.h \
+ net/accountserver/account.cpp \
+ net/accountserver/account.h \
+ net/accountserver/accountserver.cpp \
+ net/accountserver/accountserver.h \
+ net/accountserver/internal.cpp \
+ net/accountserver/internal.h \
+ net/chatserver/chatserver.cpp \
+ net/chatserver/chatserver.h \
+ net/chatserver/guild.cpp \
+ net/chatserver/guild.h \
+ net/chatserver/internal.cpp \
+ net/chatserver/internal.h \
+ net/chatserver/party.cpp \
+ net/chatserver/party.h \
+ net/gameserver/gameserver.cpp \
+ net/gameserver/gameserver.h \
+ net/gameserver/internal.cpp \
+ net/gameserver/internal.h \
+ net/gameserver/player.cpp \
+ net/gameserver/player.h \
+ net/beinghandler.cpp \
+ net/beinghandler.h \
+ net/buysellhandler.cpp \
+ net/buysellhandler.h \
+ net/charserverhandler.cpp \
+ net/charserverhandler.h \
+ net/chathandler.cpp \
+ net/chathandler.h \
+ net/connection.cpp \
+ net/connection.h \
+ net/effecthandler.cpp \
+ net/effecthandler.h \
+ net/guildhandler.cpp \
+ net/guildhandler.h \
+ net/internal.cpp \
+ net/internal.h \
+ net/inventoryhandler.cpp \
+ net/inventoryhandler.h \
+ net/loginhandler.cpp \
+ net/loginhandler.h \
+ net/logouthandler.cpp \
+ net/logouthandler.h \
+ net/network.cpp \
+ net/network.h \
+ net/npchandler.cpp \
+ net/npchandler.h \
+ net/partyhandler.cpp \
+ net/partyhandler.h \
+ net/playerhandler.cpp \
+ net/playerhandler.h \
+ net/protocol.h \
+ net/tradehandler.cpp \
+ net/tradehandler.h \
+ resources/buddylist.cpp \
+ resources/buddylist.h \
+ commandhandler.cpp \
+ commandhandler.h \
+ guild.cpp \
+ guild.h
+endif
+
+if SERVER_EATHENA
+tmw_CXXFLAGS += -DEATHENA_SUPPORT
+tmw_SOURCES += \
+ gui/char_server.cpp \
+ gui/char_server.h \
+ gui/skill.cpp \
+ gui/skill.h \
+ gui/status.cpp \
+ gui/status.h \
+ net/ea/beinghandler.cpp \
+ net/ea/beinghandler.h \
+ net/ea/buysellhandler.cpp \
+ net/ea/buysellhandler.h \
+ net/ea/charserverhandler.cpp \
+ net/ea/charserverhandler.h \
+ net/ea/chathandler.cpp \
+ net/ea/chathandler.h \
+ net/ea/equipmenthandler.cpp \
+ net/ea/equipmenthandler.h \
+ net/ea/inventoryhandler.cpp \
+ net/ea/inventoryhandler.h \
+ net/ea/loginhandler.cpp \
+ net/ea/loginhandler.h \
+ net/ea/maploginhandler.cpp \
+ net/ea/maploginhandler.h \
+ net/ea/network.cpp \
+ net/ea/network.h \
+ net/ea/npchandler.cpp \
+ net/ea/npchandler.h \
+ net/ea/partyhandler.cpp \
+ net/ea/partyhandler.h \
+ net/ea/playerhandler.cpp \
+ net/ea/playerhandler.h \
+ net/ea/protocol.cpp \
+ net/ea/protocol.h \
+ net/ea/skillhandler.cpp \
+ net/ea/skillhandler.h \
+ net/ea/tradehandler.cpp \
+ net/ea/tradehandler.h \
+ party.cpp \
+ party.h
+endif
# set the include path found by configure
-INCLUDES = \
- $(all_includes) \
- -DTMW_DATADIR=\""$(pkgdatadir)/"\" \
- -DLOCALEDIR=\""$(localedir)"\"
+INCLUDES = $(all_includes)