summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac72
1 files changed, 9 insertions, 63 deletions
diff --git a/configure.ac b/configure.ac
index 4e9cffde..92366e0b 100755
--- a/configure.ac
+++ b/configure.ac
@@ -82,77 +82,23 @@ else
with_opengl=no
fi
-# FIND_PATH(programm-name, variable-name, list of directories,
-# if-not-found, test-parameter)
-AC_DEFUN([FIND_PATH],
-[
- AC_MSG_CHECKING([for $1])
- if test -n "$$2"; then
- cv_path="$$2";
- else
- cache=`echo $1 | sed 'y%./+-%__p_%'`
-
- AC_CACHE_VAL(cv_path_cache,
- [
- cv_path="NONE"
- dirs="$3"
- save_IFS=$IFS
- IFS=':'
- for dir in $PATH; do
- dirs="$dirs $dir"
- done
- IFS=$save_IFS
-
- for dir in $dirs; do
- if test -x "$dir/$1"; then
- if test -n "$5"
- then
- evalstr="$dir/$1 $5 2>&1 "
- if eval $evalstr; then
- cv_path="$dir/$1"
- break
- fi
- else
- cv_path="$dir/$1"
- break
- fi
- fi
- done
-
- eval "cv_path_$cache=$cv_path"
-
- ])
-
- eval "cv_path=\"`echo '$cv_path_'$cache`\""
-
- fi
-
- if test -z "$cv_path" || test "$cv_path" = NONE; then
- AC_MSG_RESULT(not found)
- $4
- else
- AC_MSG_RESULT($cv_path)
- $2=$cv_path
-
- fi
-])
-
-FIND_PATH(sdl-config, LIBSDL_CONFIG, [${prefix}/bin ${exec_prefix}/bin /usr/local/bin /opt/local/bin], [
- AC_MSG_ERROR([Could not find libsdl anywhere, check http://www.sdl.org])
-])
+# Search for sdl-config
+AC_PATH_PROG(LIBSDL_CONFIG, sdl-config)
if test -n "$LIBSDL_CONFIG"; then
LIBSDL_LIBS="`$LIBSDL_CONFIG --libs` -lSDL_image -lSDL_mixer -lpthread "
LIBSDL_CFLAGS="`$LIBSDL_CONFIG --cflags`"
+ AC_SUBST(LIBSDL_LIBS)
+ AC_SUBST(LIBSDL_CFLAGS)
- AC_DEFINE_UNQUOTED(HAVE_LIBSDL, 1, [Defines if your system has the LIBSDL library])
+ AC_DEFINE_UNQUOTED(HAVE_LIBSDL, 1,
+ [Defines if your system has the LIBSDL library])
else
- AC_DEFINE_UNQUOTED(HAVE_LIBSDL, 0, [Defines if your system has the LIBSDL library])
+ AC_DEFINE_UNQUOTED(HAVE_LIBSDL, 0,
+ [Defines if your system has the LIBSDL library])
+ AC_MSG_ERROR([Could not find sdl-config, check http://www.libsdl.org])
fi
-AC_SUBST(LIBSDL_LIBS)
-AC_SUBST(LIBSDL_CFLAGS)
-
AC_CONFIG_FILES([
Makefile
src/Makefile