summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac38
1 files changed, 4 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index 9622d8aa..b102e1e8 100755
--- a/configure.ac
+++ b/configure.ac
@@ -103,39 +103,10 @@ else
AC_DEFINE(USE_OPENGL, 1, [Defines if Mana should have OpenGL support])
fi
-# Enable either Manaserv or eAthena
-AC_ARG_WITH(
- [server],
- AS_HELP_STRING(
- [--with-server=ARG],
- [which server to use [[ARG=manaserv,eathena]]
- [(default=manaserv)]]
- ),
- [if test "$withval" = "yes"; then
- # default is manaserv
- with_server="manaserv"
- elif test "$withval" = "no"; then
- AC_MSG_ERROR([$PACKAGE_NAME cannot run without a server.])
- else
- with_server="$withval"
- fi],
- [with_server="manaserv"]
-)
-
-if test "$with_server" = "manaserv"; then
- AC_CHECK_LIB([enet], [enet_initialize], ,
- AC_MSG_ERROR([ *** Unable to find enet library (http://enet.bespin.org/)]))
- AC_DEFINE(MANASERV_SUPPORT, 1, [Defines if manaserv support is enabled])
-elif test "$with_server" = "eathena"; then
- AC_CHECK_LIB(SDL_net, SDLNet_Init, ,
- AC_MSG_ERROR([ *** Unable to find SDL_net library]))
- AC_DEFINE(EATHENA_SUPPORT, 1, [Defines if eAthena support is enabled])
-else
- AC_MSG_ERROR([unknown server: $with_server])
-fi
-
-AM_CONDITIONAL(SERVER_MANASERV, test "$with_server" = "manaserv")
-AM_CONDITIONAL(SERVER_EATHENA, test "$with_server" = "eathena")
+AC_CHECK_LIB([enet], [enet_initialize], ,
+AC_MSG_ERROR([ *** Unable to find enet library (http://enet.bespin.org/)]))
+AC_CHECK_LIB(SDL_net, SDLNet_Init, ,
+AC_MSG_ERROR([ *** Unable to find SDL_net library]))
AC_CONFIG_FILES([
Makefile
@@ -155,7 +126,6 @@ AC_OUTPUT
echo
echo "Build with OpenGL: $with_opengl"
-echo "Supported server: $with_server"
echo
echo "configure complete, now type \"make\""
echo