summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8293650f..9ccf1411 100755
--- a/configure.ac
+++ b/configure.ac
@@ -77,15 +77,15 @@ AC_MSG_ERROR([*** Library found but cannot find headers (guichan.sf.net) *** ]))
AM_INIT_AUTOMAKE
# Option to enable OpenGL
-AC_ARG_WITH(opengl,[ --with-opengl use OpenGL ] )
-if test "x$with_opengl" == "xyes"; then
+AC_ARG_WITH(opengl,[ --without-opengl don't use OpenGL ] )
+if test "x$with_opengl" == "xno"; then
+ with_opengl=no
+else
with_opengl=yes
OPENGL_CFLAGS=' -DUSE_OPENGL'
OPENGL_LIBS=' -lGL -lguichan_opengl'
AC_SUBST(OPENGL_CFLAGS)
AC_SUBST(OPENGL_LIBS)
-else
- with_opengl=no
fi
# Search for sdl-config