summaryrefslogtreecommitdiff
path: root/tools/dyecmd/CMakeLists.txt
diff options
context:
space:
mode:
authorYohann Ferreira <yohann_dot_ferreira_at_orange_dot_fr>2010-05-22 15:53:00 +0200
committerYohann Ferreira <yohann_dot_ferreira_at_orange_dot_fr>2010-05-27 02:21:14 +0200
commit5497d10b008bfed6b1aee8aac23fe640faebf1ad (patch)
treef03cc3d8b9b3b0ed3b34e82958da2d81257fbe05 /tools/dyecmd/CMakeLists.txt
parentaa0d2450a8e9188204d088e5c828aa1e636ba463 (diff)
downloadmana-client-5497d10b008bfed6b1aee8aac23fe640faebf1ad.tar.gz
mana-client-5497d10b008bfed6b1aee8aac23fe640faebf1ad.tar.bz2
mana-client-5497d10b008bfed6b1aee8aac23fe640faebf1ad.tar.xz
mana-client-5497d10b008bfed6b1aee8aac23fe640faebf1ad.zip
Added Cmake compilation files to the dyecmd tool.
Reviewed-by: Jaxad0127
Diffstat (limited to 'tools/dyecmd/CMakeLists.txt')
-rw-r--r--tools/dyecmd/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/dyecmd/CMakeLists.txt b/tools/dyecmd/CMakeLists.txt
new file mode 100644
index 00000000..48566648
--- /dev/null
+++ b/tools/dyecmd/CMakeLists.txt
@@ -0,0 +1,28 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+
+PROJECT(MANA_DYECOMMAND)
+
+IF (NOT VERSION)
+ SET(VERSION 1.0.0)
+ENDIF()
+
+STRING(REPLACE "." " " _VERSION ${VERSION})
+SEPARATE_ARGUMENTS(_VERSION)
+LIST(LENGTH _VERSION _LEN)
+IF(NOT (_LEN EQUAL 4 OR _LEN EQUAL 3))
+ MESSAGE(FATAL_ERROR "Version needs to be in the form MAJOR.MINOR.RELEASE[.BUILD]")
+ENDIF()
+
+LIST(GET _VERSION 0 VER_MAJOR)
+LIST(GET _VERSION 1 VER_MINOR)
+LIST(GET _VERSION 2 VER_RELEASE)
+IF(_LEN EQUAL 4)
+ LIST(GET _VERSION 3 VER_BUILD)
+ELSE()
+ SET(VER_BUILD 0)
+ENDIF()
+
+# where to look for cmake modules
+SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/CMake/Modules)
+
+ADD_SUBDIRECTORY(src)