summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2006-12-04 11:20:54 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2006-12-04 11:20:54 +0000
commiteccafb8d815068d908b998bb6c0b581b076dc78f (patch)
tree6967d3ca5fa1dc77b177c2f735469503ca04cd14 /src/Makefile.am
parent061b9e817ffe73acca163510b276e6ca7dd8f6c2 (diff)
downloadmana-client-eccafb8d815068d908b998bb6c0b581b076dc78f.tar.gz
mana-client-eccafb8d815068d908b998bb6c0b581b076dc78f.tar.bz2
mana-client-eccafb8d815068d908b998bb6c0b581b076dc78f.tar.xz
mana-client-eccafb8d815068d908b998bb6c0b581b076dc78f.zip
Introduced a new class Viewport which combines the drawing code from Engine
with the (rather misplaced) input handling from the Gui class. Also, it's a Container itself which should allow for extending it to show Guichan widgets on map coordinates.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 94b0f2af..3b7ed4d5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -107,6 +107,8 @@ tmw_SOURCES = graphic/imagerect.h \
gui/textfield.h \
gui/trade.cpp \
gui/trade.h \
+ gui/viewport.cpp \
+ gui/viewport.h \
gui/window.cpp \
gui/window.h \
gui/windowcontainer.cpp \
@@ -268,4 +270,4 @@ INCLUDES = \
tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) `pkg-config --libs libxml-2.0`
tmw_CXXFLAGS = -Wall -Werror $(OPENGL_CFLAGS) $(LIBSDL_CFLAGS) `pkg-config --cflags libxml-2.0` $(CURL_CFLAGS)
tmw_LDADD = $(LIBSDL_LIBS) -lguichan_sdl $(OPENGL_LIBS) $(CURL_LIBS)
-tmw_TARGET = tmw \ No newline at end of file
+tmw_TARGET = tmw