summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorIra Rice <irarice@gmail.com>2009-03-11 18:06:30 -0600
committerIra Rice <irarice@gmail.com>2009-03-11 18:06:30 -0600
commitc2ae6d9cea9fc3d861e73d4cf7eca5284519758e (patch)
treee52abe836ff96446ec3109cf7c273dd7ee35c1e8 /src/Makefile.am
parent6b538196a799525d8ad4bf5cb5affe87745d4242 (diff)
downloadmana-client-c2ae6d9cea9fc3d861e73d4cf7eca5284519758e.tar.gz
mana-client-c2ae6d9cea9fc3d861e73d4cf7eca5284519758e.tar.bz2
mana-client-c2ae6d9cea9fc3d861e73d4cf7eca5284519758e.tar.xz
mana-client-c2ae6d9cea9fc3d861e73d4cf7eca5284519758e.zip
Added a new Popup class, which overall is functionally similar to the
Window class, but stripped down to the bare essential functionality to just draw and position them. This means no resizing, no close buttons, no ability to move them, etc. This should help reduce the overhead in drawing speech bubbles, as well as other popup type dialogs, but is also not a drop in replacement for the Window class as well. Signed-off-by: Ira Rice <irarice@gmail.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 440c020e..c4265dec 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -94,6 +94,8 @@ aethyra_SOURCES = gui/widgets/dropdown.cpp \
gui/passwordfield.h \
gui/playerbox.cpp \
gui/playerbox.h \
+ gui/popup.cpp \
+ gui/popup.h \
gui/popupmenu.cpp \
gui/popupmenu.h \
gui/progressbar.cpp \