summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBjörn Steinbrink <B.Steinbrink@gmx.de>2005-07-17 21:10:44 +0000
committerBjörn Steinbrink <B.Steinbrink@gmx.de>2005-07-17 21:10:44 +0000
commit9bf3338f82bfbd425debb2855d015c7bd0e33989 (patch)
treeba390f42ebb7149e91c3494bc6a4ef3ac919ae22 /src/Makefile.am
parentfbf19c2cdde592b126fe91c0dfff480f1318f50c (diff)
downloadmana-client-9bf3338f82bfbd425debb2855d015c7bd0e33989.tar.gz
mana-client-9bf3338f82bfbd425debb2855d015c7bd0e33989.tar.bz2
mana-client-9bf3338f82bfbd425debb2855d015c7bd0e33989.tar.xz
mana-client-9bf3338f82bfbd425debb2855d015c7bd0e33989.zip
Added Item and Equipment class and made the appropriate places make use of them. Plus some cleanups.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6851a7e7..e5cd02f3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,5 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
bin_PROGRAMS = tmw
tmw_SOURCES = graphic/spriteset.cpp \
graphic/spriteset.h \
@@ -132,12 +134,16 @@ tmw_SOURCES = graphic/spriteset.cpp \
configuration.h \
engine.cpp \
engine.h \
+ equipment.cpp \
+ equipment.h \
floor_item.cpp \
floor_item.h \
game.cpp \
game.h \
graphics.cpp \
graphics.h \
+ item.cpp \
+ item.h \
log.cpp \
log.h \
main.cpp \