summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2005-02-19 13:07:08 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2005-02-19 13:07:08 +0000
commit919d5a60b08bb39114d73295c59290a6c3402a76 (patch)
treeb3173d271d30cfbf69c324b14daf94286219fa68 /src/Makefile.am
parent360b1d4d6ca420ae98f87af166d739b34f05de22 (diff)
downloadmana-client-919d5a60b08bb39114d73295c59290a6c3402a76.tar.gz
mana-client-919d5a60b08bb39114d73295c59290a6c3402a76.tar.bz2
mana-client-919d5a60b08bb39114d73295c59290a6c3402a76.tar.xz
mana-client-919d5a60b08bb39114d73295c59290a6c3402a76.zip
Fixed searching for zip files in Linux, fixed initialization of PhysFS to be
before it is used and added a start on the map reader.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7cdf49a9..f7a8cfbb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -78,6 +78,8 @@ tmw_SOURCES = graphic/graphic.cpp \
net/win2linux.h \
resources/image.cpp \
resources/image.h \
+ resources/mapreader.cpp \
+ resources/mapreader.h \
resources/resource.cpp \
resources/resource.h \
resources/resourcemanager.cpp \
@@ -105,5 +107,5 @@ INCLUDES= $(all_includes)
# the library search path.
tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) -lguichan_sdl -lguichan `pkg-config --libs libxml-2.0`
tmw_CXXFLAGS = $(LIBSDL_CFLAGS) `pkg-config --cflags libxml-2.0`
-tmw_LDADD = $(LIBSDL_LIBS) -lguichan_opengl -lguichan -lGL
+tmw_LDADD = $(LIBSDL_LIBS) -lguichan_opengl -lguichan -lGL -lphysfs
tmw_TARGET = ../tmw