summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlexander Baldeck <alexander@archlinux.org>2004-12-16 17:02:03 +0000
committerAlexander Baldeck <alexander@archlinux.org>2004-12-16 17:02:03 +0000
commit7586735e3d74f1156f3d8791b90f345e4a39f4cf (patch)
treee6f2762b604ffc06df1adae13cce63e953149ee2 /src/Makefile.am
parentce31ca0f779640dce850a9afcccfc4be6c500574 (diff)
downloadmana-client-7586735e3d74f1156f3d8791b90f345e4a39f4cf.tar.gz
mana-client-7586735e3d74f1156f3d8791b90f345e4a39f4cf.tar.bz2
mana-client-7586735e3d74f1156f3d8791b90f345e4a39f4cf.tar.xz
mana-client-7586735e3d74f1156f3d8791b90f345e4a39f4cf.zip
part of autotools update
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 00000000..2702032e
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,34 @@
+bin_PROGRAMS = tmw
+tmw_SOURCES = sound/sound.cpp \
+ graphic/2xsai.cpp \
+ graphic/graphic.cpp \
+ gui/chat.cpp \
+ gui/skill.cpp \
+ gui/shop.cpp \
+ gui/stats.cpp \
+ gui/npc.cpp \
+ gui/setup.cpp \
+ gui/gui.cpp \
+ gui/login.cpp \
+ gui/mw_button.cpp \
+ gui/mw_checkbox.cpp \
+ gui/char_server.cpp \
+ gui/char_select.cpp \
+ gui/inventory.cpp \
+ net/network.cpp \
+ net/protocol.cpp \
+ being.cpp \
+ game.cpp \
+ main.cpp \
+ map.cpp \
+ log.cpp \
+ astar.cpp
+
+# set the include path found by configure
+INCLUDES= $(all_includes)
+
+# the library search path.
+tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) $(LIBALLEGRO_RPATH)
+tmw_CXXFLAGS = $(LIBSDL_CFLAGS) $(LIBALLEGRO_CFLAGS)
+tmw_LDADD = $(LIBSDL_LIBS) $(LIBALLEGRO_LIBS)
+tmw_TARGET = ../tmw \ No newline at end of file