summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2005-06-05 18:17:04 +0000
committerBjørn Lindeijer <bjorn@lindeijer.nl>2005-06-05 18:17:04 +0000
commit732d52d4fcb3a1ae644e6d82b2b69fbfa2efaf51 (patch)
treef09bb3b8c34cdfd78f8346460fabac7b2f21ddf8 /src/Makefile.am
parentaba239393ecd298e8ffd16e0b6a5d86837c594ae (diff)
downloadmana-client-732d52d4fcb3a1ae644e6d82b2b69fbfa2efaf51.tar.gz
mana-client-732d52d4fcb3a1ae644e6d82b2b69fbfa2efaf51.tar.bz2
mana-client-732d52d4fcb3a1ae644e6d82b2b69fbfa2efaf51.tar.xz
mana-client-732d52d4fcb3a1ae644e6d82b2b69fbfa2efaf51.zip
Using custom focus handler to work around problem with multiple widgets
requesting modal focus using a stack based approach.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 85878bbb..2c579825 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,6 +25,8 @@ tmw_SOURCES = graphic/spriteset.cpp \
gui/confirm_dialog.h \
gui/equipment.cpp \
gui/equipment.h \
+ gui/focushandler.cpp \
+ gui/focushandler.h \
gui/gui.cpp \
gui/gui.h \
gui/help.cpp \
@@ -142,7 +144,7 @@ INCLUDES = \
-DTMW_DATADIR=\""$(pkgdatadir)/"\"
# the library search path.
-tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) -lguichan_sdl -lguichan `pkg-config --libs libxml-2.0`
+tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) `pkg-config --libs libxml-2.0`
tmw_CXXFLAGS = -Wall $(OPENGL_CFLAGS) $(LIBSDL_CFLAGS) `pkg-config --cflags libxml-2.0`
-tmw_LDADD = $(LIBSDL_LIBS) -lguichan $(OPENGL_LIBS) -lphysfs
+tmw_LDADD = $(LIBSDL_LIBS) -lguichan_sdl -lguichan $(OPENGL_LIBS) -lphysfs
tmw_TARGET = tmw