summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-08-05 16:21:56 +0000
committerGuillaume Melquiond <guillaume.melquiond@gmail.com>2007-08-05 16:21:56 +0000
commit1828eee6a6d91fd385ad1e69d93044516493aa91 (patch)
tree9e7e86955e2d79f4f21daacf009312efd90dc70e /src/Makefile.am
parent52abf02fb5521a00e78903addda6f8a20896f18f (diff)
downloadmana-client-1828eee6a6d91fd385ad1e69d93044516493aa91.tar.gz
mana-client-1828eee6a6d91fd385ad1e69d93044516493aa91.tar.bz2
mana-client-1828eee6a6d91fd385ad1e69d93044516493aa91.tar.xz
mana-client-1828eee6a6d91fd385ad1e69d93044516493aa91.zip
Added support for internationalization. Tested by translating a few gui strings to french.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0ccdd777..42b9d262 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -194,6 +194,7 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
resources/equipmentdb.cpp \
resources/equipmentdb.h \
resources/equipmentinfo.h \
+ resources/gettext.h \
resources/image.cpp \
resources/image.h \
resources/imagewriter.cpp \
@@ -306,4 +307,5 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
# set the include path found by configure
INCLUDES = \
$(all_includes) \
- -DTMW_DATADIR=\""$(pkgdatadir)/"\"
+ -DTMW_DATADIR=\""$(pkgdatadir)/"\" \
+ -DLOCALEDIR=\""$(localedir)"\"