summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRodney Dawes <dobey@novell.com>2005-05-01 19:26:24 +0000
committerRodney Dawes <dobey@novell.com>2005-05-01 19:26:24 +0000
commitf61fc8ef256f43d1ada47fb5851f8954fea4cdea (patch)
tree210b0ad30ed690b63576da561954091987622fb3 /src/Makefile.am
parent893cde9e754b805f1e62c517740919c04d9490e0 (diff)
downloadmana-client-f61fc8ef256f43d1ada47fb5851f8954fea4cdea.tar.gz
mana-client-f61fc8ef256f43d1ada47fb5851f8954fea4cdea.tar.bz2
mana-client-f61fc8ef256f43d1ada47fb5851f8954fea4cdea.tar.xz
mana-client-f61fc8ef256f43d1ada47fb5851f8954fea4cdea.zip
- Added installation of game data, install required on *nix systems
- Updated desktop file to work better - Install the desktop file to the standard location - Install the icon as tmw.png in the standard pixmaps data dir
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 47bb0cb5..067736a3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -125,7 +125,9 @@ tmw_SOURCES = graphic/spriteset.cpp \
sound.h
# set the include path found by configure
-INCLUDES= $(all_includes)
+INCLUDES = \
+ $(all_includes) \
+ -DTMW_DATADIR=\""$(pkgdatadir)/"\"
# the library search path.
tmw_LDFLAGS = $(all_libraries) $(LIBSDL_RPATH) -lguichan_sdl -lguichan `pkg-config --libs libxml-2.0`