summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJared Adams <jaxad0127@gmail.com>2010-04-22 07:15:35 -0600
committerJared Adams <jaxad0127@gmail.com>2010-04-23 08:33:25 -0600
commitc22ea2f169f58e765fc699fcd71bfd3a3cd4f859 (patch)
tree9e19b57d562d3fe24cd69e6441db41162aa6d3e4 /src/CMakeLists.txt
parent93d4de19fdffb6d568c907729449f169c3520c7b (diff)
downloadmana-client-c22ea2f169f58e765fc699fcd71bfd3a3cd4f859.tar.gz
mana-client-c22ea2f169f58e765fc699fcd71bfd3a3cd4f859.tar.bz2
mana-client-c22ea2f169f58e765fc699fcd71bfd3a3cd4f859.tar.xz
mana-client-c22ea2f169f58e765fc699fcd71bfd3a3cd4f859.zip
Add an Actor class to replace the Sprite class
The Actor class manages the Map reference, position vector, and alpha float. These are the common parts from it's children.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 02a08bfe..3c9e6e82 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -400,6 +400,8 @@ SET(SRCS
utils/mkdir.h
utils/xml.cpp
utils/xml.h
+ actor.cpp
+ actor.h
animatedsprite.cpp
animatedsprite.h
animationparticle.cpp
@@ -487,7 +489,6 @@ SET(SRCS
simpleanimation.h
sound.cpp
sound.h
- sprite.h
statuseffect.cpp
statuseffect.h
text.cpp