summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorChuck Miller <shadowmil@gmail.com>2010-07-12 21:45:50 -0400
committerChuck Miller <shadowmil@gmail.com>2010-07-13 17:31:00 -0400
commit7ae52ac5392607f5cb56dffa9ae45ae5a2f14bd1 (patch)
treed07c53931d0fe987caa19378c9ed14d381749736 /src/CMakeLists.txt
parentc8aa6f18406459426fe0914d23181eb1e61f0137 (diff)
downloadmana-client-7ae52ac5392607f5cb56dffa9ae45ae5a2f14bd1.tar.gz
mana-client-7ae52ac5392607f5cb56dffa9ae45ae5a2f14bd1.tar.bz2
mana-client-7ae52ac5392607f5cb56dffa9ae45ae5a2f14bd1.tar.xz
mana-client-7ae52ac5392607f5cb56dffa9ae45ae5a2f14bd1.zip
Add the foundation for the event system
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c632de66..d4845085 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -439,6 +439,10 @@ SET(SRCS
emoteshortcut.cpp
emoteshortcut.h
equipment.h
+ event.cpp
+ event.h
+ eventmanager.cpp
+ eventmanager.h
flooritem.cpp
flooritem.h
game.cpp
@@ -462,6 +466,8 @@ SET(SRCS
joystick.h
keyboardconfig.cpp
keyboardconfig.h
+ listener.cpp
+ listener.h
localplayer.cpp
localplayer.h
log.cpp
@@ -507,6 +513,7 @@ SET(SRCS
tileset.h
units.cpp
units.h
+ variabledata.h
vector.cpp
vector.h
)