summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBjørn Lindeijer <bjorn@lindeijer.nl>2009-05-04 23:26:22 +0200
committerBjørn Lindeijer <bjorn@lindeijer.nl>2009-05-04 23:41:45 +0200
commit6cacaa3d7f55d91d8b7ca178f8595cc6c6b4383d (patch)
treea4ae355fe26eda518a5fd82c15347b6cfcf6b7f6 /src/CMakeLists.txt
parent1b06ec9f12e3fbfe6fbf6579fb64bb895464badb (diff)
downloadmana-client-6cacaa3d7f55d91d8b7ca178f8595cc6c6b4383d.tar.gz
mana-client-6cacaa3d7f55d91d8b7ca178f8595cc6c6b4383d.tar.bz2
mana-client-6cacaa3d7f55d91d8b7ca178f8595cc6c6b4383d.tar.xz
mana-client-6cacaa3d7f55d91d8b7ca178f8595cc6c6b4383d.zip
Replaced emote window with a new emote popup
The popup is meant to be temporary, showing the emote instantly when you click on it. It adapts nicely to show any number of emotes. I still need to add a better way of assigning emote shortcuts, since currently you can only change which emote is assigned to which shortcut by actually using it.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 299d75f8..d5f8c9a7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -128,10 +128,10 @@ SET(SRCS
gui/debugwindow.h
gui/emotecontainer.cpp
gui/emotecontainer.h
+ gui/emotepopup.cpp
+ gui/emotepopup.h
gui/emoteshortcutcontainer.cpp
gui/emoteshortcutcontainer.h
- gui/emotewindow.cpp
- gui/emotewindow.h
gui/equipmentwindow.cpp
gui/equipmentwindow.h
gui/focushandler.cpp
@@ -155,8 +155,6 @@ SET(SRCS
gui/linkhandler.h
gui/login.cpp
gui/login.h
- gui/menuwindow.cpp
- gui/menuwindow.h
gui/minimap.cpp
gui/minimap.h
gui/ministatus.cpp
@@ -230,6 +228,8 @@ SET(SRCS
gui/updatewindow.h
gui/viewport.cpp
gui/viewport.h
+ gui/windowmenu.cpp
+ gui/windowmenu.h
net/adminhandler.h
net/charhandler.h
net/chathandler.h