summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-02-25 22:28:13 +0100
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-02-25 23:18:35 +0100
commitd1f7e4f5090ac61142415edaa51f2af86aecc188 (patch)
tree710c96208bd4ada7f6e19ea6200048b4438c61a2 /src/CMakeLists.txt
parent861b28494e8c0f8701c093f82f152c3bcdbae9fd (diff)
downloadmana-client-d1f7e4f5090ac61142415edaa51f2af86aecc188.tar.gz
mana-client-d1f7e4f5090ac61142415edaa51f2af86aecc188.tar.bz2
mana-client-d1f7e4f5090ac61142415edaa51f2af86aecc188.tar.xz
mana-client-d1f7e4f5090ac61142415edaa51f2af86aecc188.zip
Added paste facility from the Wormux project
With CMakeLists.txt adaptions from the Aethyra project. Reviewed-by: Bernd Wachter Reviewed-by: Jared Adams
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index eda28b38..b84e59c6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -55,6 +55,12 @@ IF (WITH_OPENGL)
SET(FLAGS "${FLAGS} -DUSE_OPENGL")
ENDIF (WITH_OPENGL)
+IF (USE_X11)
+ FIND_PACKAGE(X11 REQUIRED)
+ INCLUDE_DIRECTORIES(${X11_INCLUDE_DIR})
+ SET(FLAGS "${FLAGS} -DUSE_X11")
+ENDIF (USE_X11)
+
INCLUDE_DIRECTORIES(
${CMAKE_CURRENT_SOURCE_DIR}
${SDL_INCLUDE_DIR}
@@ -378,6 +384,8 @@ SET(SRCS
resources/wallpaper.h
utils/base64.cpp
utils/base64.h
+ utils/copynpaste.cpp
+ utils/copynpaste.h
utils/dtor.h
utils/gettext.h
utils/mathutils.h